BLank new application build success, but crash at start of application

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • Hi, please help me somebody!

    I try to build and run empty blank new project with android exporter.

    I use CLickteam fusion 2.5, developer version, buyed at STEAM.

    I've already install JDK - jdk1.8.0_121 - now installed 64 bit version, but 32 bit I tried too.
    I've already install SDK without IDE (lost link at that moment, try to find if need)
    Then I've already download Android-Installation-Checker from this site, and this tool say "All is ok".
    I've already run SDK manager and download SDK's for a lot of lastest API's.
    In android exporter settings I put one of this API.
    And click build.
    App build success.

    Then I install APK at virtual device (genymotion) and one real device, but in both cases application crash at start.
    In settings I use OpenGL 1.1, and tried already to turn on/off GPU setting.

    Please help, what I do wrong and how to determinate pricecly cause of crash?

    EDIT: In preferences I've already put both pathnames.

  • I'm having the same problem. I am using the steam version developer and android exporter. I have tried on multiple phones and computers.

    I have also tried what Sergey posted above (I must admit my jdk was outdated), but it still crashes.

  • Guys, my application work VERY VERY slow after run on virtual device. 1 fps. :) Even after disable all of my code. Even after stop all animation... I use Sergey's advice - sign my app and make release version. Signed APk work 20-30 fps! And I can optimize my game now! I post this to help someone. :) Thanks for all!

  • I'm not shure, must I post this here or in new thread, but... I have still problems with android.
    Fundamental question - what version of OpenGL I need set in options of application?

    My results:
    OpenGL 1.1 - my application run ONLY on API 24 virtual device (genymotion), good speed ~ 50-60 fps. Only shaders not work and need to recoding, but all other things worked.

    Why application can run only on API 24?

    OpenGL 1.1 - other virtual devices on other API's crashed at startup (as I say at start of this thread) with genymotion exception for nvoglv32.DLL. So I think it's problem with OpenGL settings...

    OpenGL 1.1 - real device (4.2.2) - application runs, but fps is super slow (1-5 fps), and application randomly draw at screen very strange solid color triangles...
    I think it's problem with opengl.

    Then I try to choose OpenGL 2.0 and 3.0. In both cases application runs at API 16 of genymotion virtual device, but with 20-30 fps on frame with one picture and 20-30 string of code, and 1-2 fps on my game-level screen.
    Very weird.

    Why openGL 1.1 on API 24 so fast, and why 2.0 and 3.0 on API 16 so weird slow?

    Can somebody answer me? Help me please!

  • Fernando, thanks for answer! I post issue on bug tracker. And register my steam id to forum. But I'm not shure, need I register somewhere license key for product? And I can't find it in steam. At my name on forum don't display icons, just Clicker. :) What must I do? Or is that enough?

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!