exporting failed to android

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • ( i already downloaded android studio and java )

    problem 1: so, i see some other post that says i need to make the correct path at tools - perferences - general.. i set it to android, set the path exactly same with the post i see.. then i close it. when i open it again, it become SWF again, no matter how many times i set it.. it will be SWF when i open it again.. even when i restart clickteam fusion...

    problem 2: also when i read other post in the forum.. the correct path is
    (C:\Users\dstroud\tools\ant\build.xml )
    my error is :
    (C:\Users\WINDOWS8\AppData\Local\Temp\AndFCED.tmp\build.xml:84: Cannot find C:\Users\WINDOWS8\AppData\Local\Android\sdk\tools\tools\ant\build.xml imported from C:\Users\WINDOWS8\AppData\Local\Temp\AndFCED.tmp\build.x)
    there are 2 "tools" there.. and i have no idea how to fix it...

    problem 3: i dont know if the file is hidden or something, but when i try to search the file "ant\build.xml" i just cant find it anywhere.. i search it on google, and it says that i need to download another program again, i downloaded... same result, so i deleted it.. i also tried to search the path on the preferences - general.. and i cant find it too.. i even re installed android studio... the same result happened

    Edited 3 times, last by PGUp (April 17, 2017 at 5:14 AM).

  • Hey, I haven't used Clickteam in a while anymore so I'm not sure if I'm 100% correct on this, and I'm not home right now so I can't check, but I don't think Android Studio is what you need to be able to export to Android. I assume you used an outdated post or pdf that brought you to Android Studio because I vaguely recall having done that myself.

    I think what you need is the Android SDK Manager or Android SDK Tools or something like that. Then use that to download the SDK for the Android version you want to develop your app for. Clickteam should automatically find it afterwards (you won't have to put the file path).

  • The Android SDK Manager and Android SDK Tools are a part of Android Studio. They are no longer available separately as far as I can recall/as best as I can tell.

    My Please login to see this link. (which I actually use), my Please login to see this link. (which I mostly don't use), and my Please login to see this link. (which I don't use anymore pretty much at all really). If there are awards for "'highest number of long forum posts", then I'd have probably won at least 1 by now. XD

  • Please login to see this link. --> if you look at the changelog from "SDK Tools, Revision 25.3.0 (March 2017)" you will see they removed ant thats why its not working.

    You need this --> Please login to see this link. --> API 24.

    But thats said already in lot of threads ;) --> Please login to see this link.

  • Hi there. I had a question about that. I know that we need to get the api 14 in the manager. Is there anything else that we need to install in the sdk manager? Once we are done and then we go to fusion. We put the directory to the jdk and sdk. Do we just put the directory of the main sdk program folder?... or do we need to put the directory to a specific folder in the sdk files?

  • Actually what I do is get the sdk manager (link is left by this person named manuel) and java and download api 14 from sdk manager. When your installing the sdk manager I highly suggest you to put it in the "Program files" in your pc. Then in fusion you put the path of those 2 tools. After that just in case if the build gets an error even you put the path correctly, go to your app properties and on the compression level, change it to maximum. It worked for me!

  • The Android SDK Manager and Android SDK Tools are a part of Android Studio. They are no longer available separately as far as I can recall/as best as I can tell.

    They are still available. And that's what I recommend, and made a sticky of it.
    10's of Threads with the same problem, and it's all because of Android Studio.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!