Ironsource object does not show ads

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • Hi,

    I am trying to show ads using the ironsource object but something is off.

    What I have done so far:
    - I created an account in Ironsource; they approved the app few days later and it is currently LIVE.
    - I want to run only interstitial ads . I am using the "code" below to start them . Currently, I want to test it only with their network.
    - In the object itself - I have clicked only "Enable interstitial" and in the Application ID I have entered the app key from ironsource Please login to see this attachment.

    Still - no ads. I followed their procedure for troubleshooting Please login to see this link. and added test device with test ads but they did not show neither .

    I have a very simple code for running intersititial ads:
    * Start of Frame
    IronSource : Load Interstitial

    * IronSource: On Interstitial Ready
    + Run this event once
    + Layer object: Layer 6 is visible? // this is the win/loose condition
    + Delay_ads > 5
    IronSource : Show Interstitial

    Any ideas what could be wrong ?

  • what mediation did you add?


    I wanted to test it with only Ironsource's network . That is why nothing else is clicked Please login to see this attachment. (I am waiting for Chartboost's approval of the app). But since I added a test device - I expected to see at least test ads (and then - later on - to add further networks). Should I just add further networks and wait ?

  • Also, I might be missing something big here (still newbie) , because even the example file for the Ironsource does not work for me.

    What I did - I added a test app in my ironsource account. Then copied the APP KEY: e512e*** (from Ironsource dashboard) to the field Android->"Application ID:" in the ironsource object. In the dashboard of ironsource - I enabled test devices and test ads. Still, when I compile the example and run it - it keeps popping error 509 and 510 (interstitial show failed , interstitial load failed).

  • seems that something is missing at your dashboard. Better ask them (IronSource) if everything is correctly set

    Thanks, I sent them an email. They should reply on 4th-5th

    In the mean time - is there something I can read further (like a tutorial on the subject) ? In the dashboard - I see sessions (even of my test app) Please login to see this attachment. and two days ago I got an email from them that everything has been approved and running:
    Your ironSource account has been approved, and your app is now live on the ironSource network. This means that your app is receiving live inventory, and may have already started earning revenue " .

  • seems that something is missing at your dashboard. Better ask them (IronSource) if everything is correctly set


    I just got an email from them that everything seems fine in the dashboard. I even tried to setup a different account (just for testing purposes) with a new test app, got the ID of the app and plugged in into the example file. Still no ads ("Video available , but when I click on it - "Interstitial failed" ). Error codes are 509 and 510 .
    Can you help me , because currently this is the only way I can show ads ( Chartboost rejected my apps with the chartboost object : "Unfortunately, we do not officially support Clickteam Fusion integration. The SDK version in this integration (7.3.1) is simply too low and does not meet our minimum requirements as it does not support the GDPR or CCPA guidelines, as well as still has some (now solved) bugs. )

  • seems that something is missing at your dashboard. Better ask them (IronSource) if everything is correctly set

    Hi Fernando,

    Could you please check my issue ? As said before - Ironsource checked the account - everything is fine. But I can't show ads even in the example file. I tried every idea that I came up with to fix this issue but with no luck.

    As a starting point - could you please confirm that this object still works?
    Or I can send you my test device GAID and you can add it to the "testing devices" in the app in the example (with APP ID 4ea90fad ). If it works - then the issue should be somewhere in the account.

    My only wish is to show test ads using the example file, nothing more.

  • please send me a mfa for me to check here, (only ironsource code ACE) by PM using cloud services

    also mention what mediation you have enabled in your account which shoudl be the same as in your mfa

    Hi, I sent you a message . Have you received it? I think there is an error with the object, because Ironsource said that they have tested with a test app and they can see test adds (while I can't do that if I use the object):
    "I have checked your account settings, and for test app e5436d**
    Everything looks good, as I am able to get and watch ironSource test ads using your appKey and configurations.

    Then I believe your issue maybe related to the integration & implementation,
    can I suggest you download our Demo App from our Knowledge Center....:"

  • With your App Id only see offer wall empty, but with the rest it says integration is OK, i believe the adapter are outdated, so the object need to be updated, unfortunately for this need time to review all changes they made since 2019


    Fernando Vivolo

    ... new things are coming ...

  • Sadly these changes make this as a new object, it is on my list to-do not sure all changes requires what will be the result.

    I've been trying to show ads, but everytime it gives me an error with any mediation that I use that says "Received status code 403 from server: Forbidden" even in the examples files. Am I doing something wrong

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!