Another Google SDK update: com.google.android.play:core

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

Clickteam.
  • Here is a Please login to see this link. for the stand-alone version of Fusion (if you guys can test it we'll push it to Steam too). It should fix the Play Core library warnings.

    If any issue, you can reinstall the Please login to see this link. of the Android runtime for the build 295.10.

    I update and found

    SDK issues in your latest production release

    • com.google.android.play:core:1.10.3

      Google Play Core (com.google.android.play:core) has added this note for SDK version 1.10.3:

      Update your Play Core Maven dependency to an Android 14 compatible version! Your current Play Core library is incompatible with targetSdkVersion 34 (Android 14), which introduces a backwards-incompatible change to broadcast receivers to improve user security. As a reminder, from August 31, Google Play requires all new app releases to target Android 14. Update to the latest Play Core library version dependency to avoid app crashes: Please login to see this link.


      From September 22, 2024 00:00 (UTC) you won't be able to release new versions of your app containing this SDK version to production or open testing.

    If you have questions about this SDK, contact the provider.

  • pradeep - Google Play doesn't take the message away until you go to your inbox and archive it. They show which version of your app its applicable to.

    For example on my app:

    Affected app bundles and APKs:

    • version: 7 (1.06), release:.7(1.06)

    And version 9 is currently pending review. (I discarded version 8).

    Casual games: Please login to see this link.

  • pradeep - Google Play doesn't take the message away until you go to your inbox and archive it. They show which version of your app its applicable to.

    For example on my app:

    Affected app bundles and APKs:

    • version: 7 (1.06), release:.7(1.06)

    And version 9 is currently pending review. (I discarded version 8).

    Thanks Please login to see this link.

  • Here is a Please login to see this link. for the stand-alone version of Fusion (if you guys can test it we'll push it to Steam too). It should fix the Play Core library warnings.

    If any issue, you can reinstall the Please login to see this link. of the Android runtime for the build 295.10.

    This patch don't work on the steam version. :(

    • New
    • Official Post

    This patch don't work on the steam version. :(

    Yves
    June 25, 2024 at 8:30 AM
    • New
    • Official Post

    The Please login to see this link. has been updated and now includes the line that solved Janette5's issue (as usual if any issue,you can reinstall the Please login to see this link. of the Android runtime for the build 295.10).

    The Steam version is now available as "beta version", i.e. to install it you need to suscribe to beta versions in the settings of Fusion in your Steam client, and enter the code x243TNkwZS1239

  • The Please login to see this link. has been updated and now includes the line that solved Janette5's issue (as usual if any issue,you can reinstall the Please login to see this link. of the Android runtime for the build 295.10).

    The Steam version is now available as "beta version", i.e. to install it you need to suscribe to beta versions in the settings of Fusion in your Steam client, and enter the code x243TNkwZS1239

    I change to beta version on steam, and it work for me! :)

    Thanks for help.

  • I tried to publish an update on a game that target android 14 and use Google IN-APP object, and i got this error message:
    This app targets Android 14 or above, and your current Play Billing Library version doesn't support Android 14. To target the latest Android version, please update your PBL version to either 5.2.1, or 6.0.1 and above.


    What i find strange is that i published an updates using Target Android 14 with In-App object on 7 days ago, before to install this fix, with no error message. So i don't know if it's because of this fix or that google just changed its rules.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!