[Solved] Build FAILED: "app: SignReleaseBundle"

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • I'm at a complete loss with this.

    My app continually fails to build when using the key generated by Android Studio (.jks) with the following exception in the error log.

    It builds successfully if I build an unsigned app, or if I use an old .keystore key generated by the (presumably deprecated) Keystore Generator Tool. However, Google Play does not accept an app bundle signed using this old tool.

    Fusion doesn't even seem to recognise the .jks file when you navigate to the folder containing this key, I select it anyway, but the build always fails.

    I'll just post the most relevant part of the error log. If the full log is required for assistance I'm happy to provide it. Any help with this would be greatly appreciated


    Ok, I've managed to figure out what the issue was.

    The problem was that my JDK path was pointing to another Java installation I had on my computer, and NOT the one that came with Android Studio (usually in location c:\Program Files\Android\Android Studio\jbr)

    It now builds both .apk and .aab using the.jks keystore file without issues (and faster) :)

    The previous JDK installation I pointed to was in a custom location I used when following a Android Exporter setup tutorial in an article on Steam, ironically with the intent purpose of being able to build apps WITHOUT having to download the behemoth that is Android Studio & have my hard drive clogged up with a slow & buggy IDE, and every API ever - just in case you wanted to run your fusion app on somebody's watch, toaster or doorbell :rolleyes:

    Anyway, what I'm saying is don't follow that Steam tutorial if you want to successfully build release mode .aab files for publishing, just use the Android Studio paths.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!