Quote from TilesI don`t really understand how it works
The idea is pretty basic, although the way it's implemented may not be very intuitive. In a typical world any unit can move in 8 directions (if you have diagonals), we call each of these possible moves a transition. So something like a transition with delta (0, 1) means that it will keep the X-coordinate unchanged and add 1 to the Y-coordinate, in effect meaning that the unit can move downwards. Similarly (-1,-1) means that the unit can move diagonally to the tile to the top left of its current position.
So what I did was instead of fixing those 4 or 8 transitions, I allowed the user to specify them manually. So they don't need to be limited to the defaults where a unit can only move to adjacent tiles. In the chess example the knight piece can move with a transition like (2, 1) which means it can jump 2 tiles to the right and one tile downwards.
That would have been all, except that I've added this "conditions" thing to complicate matters. The conditions for a transition has to be true to allow the unit to use this transition. Typically this means that the destination tile has to empty, and this is the case in the chess example. The reason I didn't automate this and make it use only that test, is that sometimes you need more than just that. If you recall in our previous experiments, some pathfinding objects found a path that is invalid because it squeezes diagonally between two obstacles. This kind of thing can't be handled if we only check that the destination tile is empty, we need to, at least, have one of the neighboring tiles empty as well.
Does this make sense?
Quote from TilesOne thing i noticed, the conditions "is an agent" and "is NOT an agent", well, why don`t you simply use negate at "is an agent" here? Would save one condition
I REALLY wanted to have a single event and spent some time trying to hack this to make it work with the help of Ross, but so far MMF doesn't like negating conditions that have object parameters.
Quote from Tileswhy not remove the "to system" part, and simply call it Add Transition?
I'll do this.
Quote from TilesThe tooltip part for Add transition is even longer and even more cryptic.
Now this one needs more precision than just "Add Transition to (1|1)" because it's very easy to overlook what it actually does. It needs to be shortened but we need to find a better wording that still makes it clear.
Quote from TilesWhat about call the Action "Add OR" ? smile
I initially decided against this name, but I guess anything would be better than the current name.