iOS WebView extension beta

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

Clickteam.
  • A few lines added to CRunWebView.m manage to simulate a user touch on the WebView's first button once it's loaded => video autoplay works on iOS >:D

    I attach the modified source file for your information. The 2 code additions are between comments about "code inserted for VIDEO AUTOPLAY" 1/2 and 2/2.
    Please login to see this attachment.

    Jjsonick, it would be really nice if you could modify your extension so that this behaviour can be switched on/off at runtime with an object action. Really nice because it would allow us to use some WebView objects for video autoplay, and some other ones for any other purposes. I would try and do it myself if I had the extension development skill.

    What do you think?

  • Just wanted to say that this doesn't seem to really do anything on iOS5 or 6 with the latest Beta. It's trying to load the site (my LittleSnitch asks me if I approve a connection with the site I'm trying to load) but the page just shows up blank.

    I know the developer isn't really working on this anymore which is a pity. It's a little bit beyond my current Obj-C knowledge but I will have a look into fixing it soon.

  • I have the same problem, i would like to update an application made with this extension (and working fine). But when i try on iphone and on the multimedia fusion runtime the page stay blank.

    There is a solution ?

  • I need to use this extension, but it doesn't seem to be working anymore. It's just showing a blank page.
    Anyone have any ideas for how to fix this?

    Nevermind. I managed to get it to load.

    Just comment out the line:

    Code
    webView.hdden=YES;

    in the "CRunWebView.m" file.

    SoapCow's first iPhone app! Available now!
    -> Please login to see this link. <-

    Please login to see this link. <- Flash portal with a focus on Clickteam made games!
    Please login to see this link. <- A cool MMF made flash game!

    Twitter:
    Please login to see this link.
    Facebook:
    Please login to see this link.

    Edited once, last by UrbanMonk (May 4, 2013 at 9:34 PM).

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!