[BUG] Maximize on startup not working

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • HI

    Another build of fullscreen mode not working with just 1 active object and default options in the .mfa

    I tried disabling all checked properties of the mfa an only enabling
    maximise on startup

    then i tried adding just change resolution

    then i tried adding the option to switch between fullscreen and window

    then i tried adding something else which i've forgotten but ill update the info with that later, it was another option for the display.

    none of them would start in fullscreen mode however every application i've tried Shift++F expands the window to fill the screen minus the dock, if the dock is hidden it fills the whole screen.

    on a little tangent why the +Shift+Q to quit? its usually +Q


    This is on my iMac setup in 10.8.4, i will test on my Macbook Pro setup a little later

  • should have been a little clearer sorry, this stemmed from one of my games that crashes immediately on startup so i thought i'd investigate more with the above.

    i've now tried different colour depths and removed several frames but it still crashes on startup.

    it was using the kcdraw extension but i deleted it before i built the app. (as its not ported for osx)

    here is the first frame that crashes

    Please login to see this attachment.

    [edit] i thought it may have been the frame transitions so i tried deleting them but hasn't fixed it. ^ attachment has frame transitions.

    Edited 2 times, last by Zem (June 26, 2013 at 9:00 AM).

  • I can't see exactly when this is happening from the .app alone unfortunately. Is there any chance I can have a look at the MFA file?

    The crash seems to happen during the creation of an object somewhere at runtime.

    Please login to see this picture. Please login to see this link. - Please login to see this picture.

  • Oh weird, I thought it was the kcdraw extension but I deleted that and rebuilt and it crashed even after removing the events that call the functions, oddly enough though I have added in an active object which does what I needed via an animation and it builds fine now, still doesn't change the display mode to fullscreen (read not the maximised window you get from using the command from the apple top context toolbar) no idea what happened, seems we have lost this to me working around it but it also seems safe to say there was a reference to the kcdraw extension somewhere even after building, maybe it was because I didn't save the mfa after removing the object and events.

    Thanks Anders, sorry that mfa has gone, I'll keep a copy in future

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!