2.5 crashing, freezing and refusing to uninstall

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • Apologies for not reporting this in the bug section but I can't access that without registering my software, and entering my serial code does nothing.

    After installing fusion 2.5, I began the breakout tutorial. Upon trying to 'run frame' the program stopped responding. After several clicks to exit, windows tried to check for a solution but the message froze. After more clicking, windows asked if I wanted to kill the fusion 2.5 process but nothing happened. I then pressed Ctrl+Alt+Del and tried to manually kill it, but that also didn't work. In the end I shut down my PC, rebooted and started the program again.

    This time, with an new empty project, I selected to 'run application' instead of frame and the same issues occurred, exactly as above. After rebooting my PC once more, I tried to uninstall the program and after a delay, the uninstaller popped up and froze almost immediately. Interestingly, there appeared to be some kind of avast tab above the progress bar. I rebooted my PC again, this time in safe mode, and successfully uninstalled fusion.

    After restarting my PC again in normal mode, I re-installed fusion (running as administrator), shut off my internet, killed avast and began the breakout tutorial again. I added the first condition and successfully ran the frame. At this point I turned both avast and my internet connection back on. I continued through the tutorial, successfully using both 'run frame' and 'run application' between adding two more conditions; however, the fourth time I tried to run frame/application (I can't remember which), the program again froze and couldn't be killed. Once more it could not be uninstalled either, though this time absolutely nothing happened or showed on screen when I tried (the uninstall process did show up in my task manager but couldn't be stopped; I had to restart in safe more again to remove it).

    At this point I can't be 100% sure Avast is the culprit, as fusion worked for ten minutes or so with it turned on. Unfortunately, if it is the source of the problem, having my internet and anti-virus off for long periods is not an option for me. I'm also reluctant to try anything else at this point, as all this resetting with processes hanging probably isn't doing my PC any good.

    Can you let me know if this is a known issue or something on my end. I cannot enter the bug tracker to check without registering my software and that's not working for me.

  • Just back from work and running virus & malware scans now (though I did so just under a month ago and everything was fine). Haven't updated windows for a couple weeks, but I always keep my drivers up to date. I'll re-install fusion after I've finished the scans/updated windows and let you know. I'm seriously considering formatting windows and switching to AVG just to see if that helps, as I've really been looking forward to using fusion 2.5 since it popped up on Steams coming soon list!

    Also, do you know of any reason my serial code isn't registering my product on the site?


  • One option might be display drivers and direct X

    Funkymunky, out of interest, does this crash happen if you set the display mode (under the application settings, 3rd tab along) of the application to "Standard"?

    Also, turning off the antivirus temporally or making an exception for Clickteam Fusion 2.5 ("mmf2u.exe") and its runtime ("edrt.exe") may help check if Avast's freaking out over edrt.exe, which some antiviruses go mental over (Norton is a good example of that.)

    Please login to see this link. - The encyclopaedia written by clickers, for the community.
    Please login to see this link. | Please login to see this link.

  • Funkymunky, out of interest, does this crash happen if you set the display mode (under the application settings, 3rd tab along) of the application to "Standard"?

    Also, turning off the antivirus temporally or making an exception for Clickteam Fusion 2.5 ("mmf2u.exe") and its runtime ("edrt.exe") may help check if Avast's freaking out over edrt.exe, which some antiviruses go mental over (Norton is a good example of that.)

    Thanks for the tips. I'm heading out for a few hours so will try these when I'm back. I didn't look through the options before as I came across the run frame/application problem straight away. My virus/malware scans have come up all clean and windows was already up to date. I'm going to re-download the exe before I re-install this time, just in case the download got corrupted before. Will post back when I'm home.


  • Okay, this is very interesting. I re-downloaded and re-installed fusion. Before running the program I added mmf2u.exe and edrt.exe to avast's exclusion list, for all types of scanning or monitoring, as lh37 suggested. I also added the uninstaller should I need to use it, as that would also hang before. So far no crashes in the twenty minutes I was playing around (I've yet to do the chocobreak tutorial again, but I don't see how that would cause any specific issue). However, I was experiencing regular and frequent stutters with any moving objects when running a frame or app; these happened like clockwork every 5 or so seconds. I tried switching between display modes but it happened on all three settings. I ran fraps but it never reported any frame rate drops, despite the clear stuttering on screen. I figured it might just be the way things run within the program, so I used to build application option to create a standalone app.

    This is where it gets interesting...

    When I launched the app (a simple 8-direction character), the frame rate way abysmal (though I stupidly closed fraps first so I don't know what the frame-rate was being reported as). I then tried to close the app and it hung, exactly as fusion would before. I also could not force the app's exe to close via ctrl-alt-del, exactly as I couldn't with fusion before. I successfully opened a second instance of the app and this time the avast tab showed up as I'd posted previously. I got a good look at it and it said 'avast deepscan'. I tried to grab a screenshot, but at this point everything froze, windows explorer crashed and I was forced to hard-reset my pc again (I'll probably have a dead pc before I have a working copy of fusion). :P

    At this point it seems obvious that there is a major conflict on my computer between avast and fusion, though it's curious that this isn't showing up elsewhere in the forum. Has anything like this been reported in the bug section? I'm going to try grab a screenshot of the avast tab and will post that if I'm successful.

    Fusion 2.5 serial number are not yet active on the forum
    We plan to add them shortly and re organize it all with Fusion 2.5 areas.

    No worries. I'm guessing this is a very busy time for you! ;)

  • Okay, I ran the app I created again to try and get a screenshot, but it hung and I couldn't use any other programs in order to do so. Long story short: explorer crashed, hard-reset again (ouch!). I can't find a picture online but the app will launch contained within a thin, light blue border, on top of which is a tab that reads 'avast deep scan'. Apologies if I'm not explaining any of this very well, I've just powered through a bunch of night-shifts plus overtime and I'm fried lol.

    Anyway, I've now disabled deep scan within avast and can successfully open and close my app, but the frame rate will still stutter, though it's more like every 20-30 seconds when running the app as a standalone.

    I think I may need a new antivirus :(

  • Sorry guys but this is massively frustrating. I'm basically sitting here with software I can't use because of numerous problems that I can't find much information about on the main forum, and I can't access the bug section because you haven't added 2.5 keys yet. I've bought something that doesn't work and I'm sitting in the dark hoping something changes. I've practically all but turned off avast, but whenever I make an app and launch the exe it will either work with lag, freeze up, or crash windows explorer. I sent a build of chocobreak to a friend, and while he was able to play it, he said his mouse went crazy at first - then later when he closed it, his cursor stayed as a spinning blue circle until he restarted windows. Am I, and now my friend, the only people having these issues? I'd love to access the bug section at some point to find out.

  • I don't believe that anyone else has encountered such issues before. Clickteam can manually give you access to the Fusion 2.5 bug tracker, if I remember correctly, so you may want to PM an administrator on here about that. I think Jeff or Francois are likely to be able to help with adding you to the Fusion 2.5 bug tracker, so I advise you PM one of them.

    My Please login to see this link. (which I actually use), my Please login to see this link. (which I mostly don't use), and my Please login to see this link. (which I don't use anymore pretty much at all really). If there are awards for "'highest number of long forum posts", then I'd have probably won at least 1 by now. XD

  • I don't believe that anyone else has encountered such issues before.

    Thanks happygreenfrog. It feels like that judging from this forum, but it was hard for me to gauge without access to the bug section. I'm worried that whatever unique issue I'm having, also found it's way onto the app I sent my friend. It's strange because I'm super fussy about keeping my PC in order (I have a lot of software and over 100 games installed on Steam and haven't had a single issue with anything else), but it really doesn't like Fusion! I've sent an email to clickteam as I tried my serial again earlier and it locked me out, so hopefully I'll also gain access to the bug section when they reset my attempts. Bugs are always a downer, but having ones that are seemingly exclusive seriously blows ;(

  • I just thought I'd post an update on the situation. I downloaded the update today and although I've only briefly ran Fusion, the previous issues I mentioned seemed to have disappeared - with exception to Avast 'deepscreen' interfering with any application (.exe) builds I run.

    Please login to see this attachment.

    These will now open and crash after a few seconds, but this is a massive improvement and something which can be remedied by disabling deepscreen (previously the app would freeze, explorer would eventually crash and windows would completely freeze and couldn't be manually closed down in any way).

    This is obviously an issue between avast and my PC, as I now have access to the bug section and see no one else has reported anything similar. My guess is my next format/re-installation of windows will solve this unique issue.

    I'm now a happy clicker ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!