Universal USB driver (adb / build and run)

Welcome to our brand new Clickteam Community Hub! We hope you will enjoy using the new features, which we will be further expanding in the coming months.

A few features including Passport are unavailable initially whilst we monitor stability of the new platform, we hope to bring these online very soon. Small issues will crop up following the import from our old system, including some message formatting, translation accuracy and other things.

Thank you for your patience whilst we've worked on this and we look forward to more exciting community developments soon!

  • Finding the right driver to enable build and run can be tricky, manufacturers (especially Samsung) often add features and change things with their drivers which prevent this fantastic feature from working.

    Clockworkmod have released a Universal ADB driver which should support pretty much anything. If you've been having issues with getting build and run to work, this may be the answer:
    Please login to see this link.
    Please login to see this link.

    Samsung Universal Android USB Driver for Windows:
    Please login to see this link.

    You may need to remove existing drivers for this to work - do so at your own risk, Clickteam cannot take any responsibility for any problems the use or installation of this driver may cause.

    Edited once, last by Olivier: Added more info (October 26, 2015 at 9:45 AM).

  • Build and Run is not working for me, I have tried the universal USB driver above but still not working, I am using the latest Beta R281.9 and Android exporter, I am using a Samsung Galaxy S V2.3.3. This set-up was working for me before, has anyone had any issues with this Beta?
    Is there a log file I could view to help locate the problem?
    The APK file builds successfully and ADB devices command shows that the S1 is connected.

  • Guys, thank you for your advice, unfortunatly I already have Development, USB debugging switched on.
    I can email the APK to myself and install it on the phone that way, but build and run was really useful and it has stopped working.
    Any other ideas please.

  • It's working on my end. Do you have a file manager on your phone? If not there are free ones on Google Play. You should be able to build the apk and save it to your desktop,..then use the phone as a storage device. Put the apk on the SD card. Then after you transfer the apk to the SD card, you can install it on your phone. I really don't know why you can't build and run though. Hopefully the CT will chime in to give you some advice.

    [SIGPIC][/SIGPIC]Please login to see this link.
    Please login to see this link.

  • I have found that I can directly install the APK to my phone with USB using the ADB install command from a ADB command window. So I guess the ABD connection must be good and the problem may be with Fusion 2.5 (is there a log file of the Build and Run process?)

    I used the command: ADB install C:/ClickTeam/[filename].apk

    For the record I opened an ADB command window by locating C:/Android/android-sdk/
    then Shift+Right Click on platform-tools and then select Open Command Window Here.

  • Another option is to use Dropbox
    Put it on your computer and on the device

    Then build your APK to Dropbox and open dropbox on your device and install the APK file
    This is also good for testing on multiple devices as its easy to get to from all of them for testing.

    Please login to see this link.

  • Allow installation on Non-Market applications is already ticked.
    My PC is running Windows 8 so maybe it is something particular to that?

    As a temporary work around I have created a batch file which installs each new version of my current project to the phone.

    Echo OFF

    CD C:/Android/android-sdk/platform-tools
    ADB devices

    ECHO Ready to install APK ?

    ADB install -r "C:\Users\...full path and filename.apk"

    ECHO Finished


  • yes that shoudl work, please avoid naming your apk with non ANSI chars also inside your project, use regular ANSI title.


    Fernando Vivolo

    ... new things are coming ...

  • I cannot get this to work either. I have installed both the Java SDK and Android Studio. At first I was getting build errors, which seems to have been fixed when I finally installed the API #14 package. Now when I select build and run with my tablet (Nvidia Shield) connected to my PC, it seems to build okay then just lock up - The green loading bar fills up and just sits there, with nothing happening on my tablet.

    I have enabled developer on the tablet, and enabled installation from unknown sources. Any ideas?

    Windows 7, Fusion 2.5 and android exporter purchased from Steam, Android version 5.0.1

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!