im working with mmf2 at school and decided to buy it so i could work on a project during the break, but when i try i get this error message;

this application requires the following extensions:
...