Note: Only works with Fusion 2.5+ add on