For the moment only 2.5+ saves incompatible MFAs if you use specific 2.5+ features like child events or custom qualifiers, the new beta doesn't (maybe it should though if you use incompatible...