If you're aiming to publish in Google Play you really should install and use build 29 - api 29 - Google will stop accepting new apps with a build below 29 some time this year.