I'm working with PHP nearly every day.

It looks like it is not even PHP 7 compatible. All mysql_... should be mysqli_... (with an i) and some need the database connection in the first parameter...