IIRC, I think you need to select the version of Flash Player you're targeting in the options somewhere. Either that, or there's a legacy code support mode you need to switch it to.