User Tag List

Page 4 of 8 FirstFirst ... 2 3 4 5 6 ... LastLast
Results 31 to 40 of 78

Thread: Users that cannot build with Android Studio (ant\build.xml error)

  1. #31
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module

    Join Date
    Jul 2008
    Location
    United States
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello - Thanks for your help. However, after doing what you said above, I now get the following message at the end of the log files...
    Are these from program commands that are incompatible with Android exporter? Thanks.
    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:888: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:890: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:902: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:283: null returned: 1

  2. #32
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,308
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    It's hard to say. This error is different.
    What API are you using, does it exist. do you have the full API.
    What is the beginning part of the log.

  3. #33
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Wodjanoi's Avatar
    Join Date
    Jun 2015
    Location
    Germany
    Posts
    650
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Another thing you should try is the uninstallation of the Java/JDK components and then reinstall everything with the JDK installer from the Oracle page.

  4. #34
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module

    Join Date
    Jul 2008
    Location
    United States
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your time. I uninstalled Android Studio and installed the two files from the links in your post.
    I am using Build Tools 27.0.3 API level:19
    However, my APK build still fails. The log file is lengthy, but the part about the failure is below...
    ========================================
    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:888: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:890: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:902: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:283: null returned: 1
    ========================================
    Do you know how I can fix this?
    Thanks again - Rich

  5. #35
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,308
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    Install the files from the first post.
    download the API's needed
    UPDATE the path in Fusion to the downloaded ones.

    Android Studio doesn't have the tools\ant that's why.

  6. #36
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Wodjanoi's Avatar
    Join Date
    Jun 2015
    Location
    Germany
    Posts
    650
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    This is Perry's thread(I think you confused me with him by accident).
    However it's always better to post the whole error log - the part before the Build Failed message might contain additional information to better spot the problem.
    Other idea: Did you try another API level yet - 21 or 25? API 19 is pretty much obsolete now, although it shouldn't lead to this type of error in Fusion in any case.
    Alternatively you can try the java + sdk manager instructions in the CF2.5 Steam Guide section - perhaps something is messed up with your previous setup and it might help to get things resolved if you go through the various steps again.

  7. #37
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module

    Join Date
    Jul 2008
    Location
    United States
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmmm... sorry. I thought I was talking to whoever gave the links to solve the "Andoid Studio" problem. I have trouble telling who is talking to who on here.
    Anyway, thanks again for your time and patience.
    Here is the whole log from the Build attempt...
    Again I downloaded installer_"r24.4.1-windows.exe" and "jdk-8u171-windows-i586.exe" and installed both. Left everything at defaults.
    I updated the API to most recent and build failed. So, I backed it down to API 19 level 19.
    The app is a simple things with a ball bouncing around on a screen and an end app button. There are some textual graphics.
    Thanks - again. - Rich
    ============================================
    Buildfile: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\build .xml

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 25.2.5
    [checkenv] Installed at C:\Program Files (x86)\Android\android-sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 27.0.3
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 4.4.2
    [gettarget] API level: 19
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\r es
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\r sObj
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\r sLibs
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\gen
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\c lasses
    [mkdir] Created dir: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\d exedLibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'debug'...
    [subant] No sub-builds to iterate on

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 377 source files to C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\c lasses
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.

    -post-compile:

    -obfuscate:

    -dex:
    [dex] input: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\bin\c lasses
    [dex] input: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\libs\ android-support-v4.jar
    [dex] input: C:\Users\Rich\AppData\Local\Temp\And7721.tmp\libs\ zip_file.jar
    [dex] Pre-Dexing C:\Users\Rich\AppData\Local\Temp\And7721.tmp\libs\ android-support-v4.jar -> android-support-v4-5386918fbca10b2eb0bd2271af4c36f3.jar
    [dx] java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 51.0
    [dx] at java.lang.ClassLoader.defineClass1(Native Method)
    [dx] at java.lang.ClassLoader.defineClassCond(ClassLoader. java:631)
    [dx] at java.lang.ClassLoader.defineClass(ClassLoader.java :615)
    [dx] at java.security.SecureClassLoader.defineClass(Secure ClassLoader.java:141)
    [dx] at java.net.URLClassLoader.defineClass(URLClassLoader .java:283)
    [dx] at java.net.URLClassLoader.access$000(URLClassLoader. java:58)
    [dx] at java.net.URLClassLoader$1.run(URLClassLoader.java: 197)
    [dx] at java.security.AccessController.doPrivileged(Native Method)
    [dx] at java.net.URLClassLoader.findClass(URLClassLoader.j ava:190)
    [dx] at sun.misc.Launcher$ExtClassLoader.findClass(Launche r.java:229)
    [dx] at java.lang.ClassLoader.loadClass(ClassLoader.java:3 06)
    [dx] at java.lang.ClassLoader.loadClass(ClassLoader.java:2 95)
    [dx] at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:301)
    [dx] at java.lang.ClassLoader.loadClass(ClassLoader.java:2 47)
    [dx] Could not find the main class: com.android.dx.command.Main. Program will exit.
    [dx] Exception in thread "main"

    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:888: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:890: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:902: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:283: null returned: 1

    Total time: 11 seconds
    ================================================

  8. #38
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,308
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    Again,
    Did you update the Android Path in the preferences so that they are pointing NOT to the Android studio.
    Also select 3.4 as min and 7.1 as Max.
    And most of them you need to go higher than API 21

  9. #39
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module

    Join Date
    Jul 2008
    Location
    United States
    Posts
    60
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Perry - Yes, I have the paths correctly listed in my preferences.
    I'm not sure what you mean by "Also select 3.4 as min and 7.1 as Max."
    Is that in the SDK Manager somewhere?

  10. #40
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,308
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    If you want I can do a Teamviewer Session with you, and show you what needs to be done.
    And I will get you up and running in no time
    Just shoot me a PM if interested with the ID and password

Page 4 of 8 FirstFirst ... 2 3 4 5 6 ... LastLast

Similar Threads

  1. Replies: 56
    Last Post: 26th December 2017, 08:53 PM
  2. Getting build error when trying to build for Android
    By Outcast in forum Android Export Module 2.5
    Replies: 7
    Last Post: 19th March 2016, 06:10 PM
  3. Android Build Error
    By dsilvers in forum Android Export Module Version 2.0
    Replies: 21
    Last Post: 28th February 2014, 12:22 AM
  4. Android Build Error
    By dsilvers in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 2nd April 2013, 01:51 AM
  5. Trying Android again... getting error 83 on build
    By Tuna in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 20th January 2013, 04:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •