User Tag List

Page 8 of 8 FirstFirst ... 6 7 8
Results 71 to 78 of 78

Thread: Users that cannot build with Android Studio (ant\build.xml error)

  1. #71
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Sep 2017
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay, so just the very top one right? Android SDK Tools 24.4.1? It says "Update available," which I install. That gets me to 25.2.5, but Fernando says that's old and outdated. Once I update it to 25.2.5 it doesn't show any more updates available. I still get the same error message when trying to build the APK in Fusion.

  2. #72
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    182
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

    my paths:
    C:\Program Files (x86)\Java\jdk1.8.0_181
    C:\Program Files (x86)\Android\android-sdk

    Got android SDK not studio,
    set to and installed API 24

    Do I have the wrong Java version maybe?

  3. #73
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,217
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    you need at least API 27/28 for Google.
    Post the beginning and end of the log. so we have more information to help you

  4. #74
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    182
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Changed to API 27 and got this..

    Buildfile: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\buil d.xml

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 25.2.5
    [checkenv] Installed at C:\Program Files (x86)\Android\android-sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 27.0.3
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 8.1.0
    [gettarget] API level: 27
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin\ res
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin\ rsObj
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin\ rsLibs
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\gen
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin\ classes
    [mkdir] Created dir: C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin\ dexedLibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'debug'...
    [subant] No sub-builds to iterate on

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 357 source files to C:\Users\blake\AppData\Local\Temp\AndE915.tmp\bin\ classes
    [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:24: error: package org.apache.http does not exist
    [javac] import org.apache.http.HttpResponse;
    [javac] ^
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:25: error: package org.apache.http does not exist
    [javac] import org.apache.http.NameValuePair;
    [javac] ^
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:26: error: package org.apache.http.client.entity does not exist
    [javac] import org.apache.http.client.entity.UrlEncodedFormEntity ;
    [javac] ^
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:27: error: package org.apache.http.client.methods does not exist
    [javac] import org.apache.http.client.methods.HttpPost;
    [javac] ^
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:28: error: package org.apache.http.impl.client does not exist
    [javac] import org.apache.http.impl.client.DefaultHttpClient;
    [javac] ^
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:30: error: cannot find symbol
    [javac] import org.apache.http.params.HttpProtocolParams;
    [javac] ^
    [javac] symbol: class HttpProtocolParams
    [javac] location: package org.apache.http.params
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:63: error: cannot find symbol
    [javac] ArrayList <NameValuePair> postData = new ArrayList <NameValuePair> ();
    [javac] ^
    [javac] symbol: class NameValuePair
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:63: error: cannot find symbol
    [javac] ArrayList <NameValuePair> postData = new ArrayList <NameValuePair> ();
    [javac] ^
    [javac] symbol: class NameValuePair
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:65: error: cannot find symbol
    [javac] postData.add(new NameValuePair()
    [javac] ^
    [javac] symbol: class NameValuePair
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:95: error: cannot find symbol
    [javac] HttpPost post = new HttpPost ("http://bugs.clickteam.com/report.php");
    [javac] ^
    [javac] symbol: class HttpPost
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:95: error: cannot find symbol
    [javac] HttpPost post = new HttpPost ("http://bugs.clickteam.com/report.php");
    [javac] ^
    [javac] symbol: class HttpPost
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:99: error: cannot find symbol
    [javac] { post.setEntity (new UrlEncodedFormEntity (postData));
    [javac] ^
    [javac] symbol: class UrlEncodedFormEntity
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:105: error: cannot find symbol
    [javac] DefaultHttpClient client = new DefaultHttpClient();
    [javac] ^
    [javac] symbol: class DefaultHttpClient
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:105: error: cannot find symbol
    [javac] DefaultHttpClient client = new DefaultHttpClient();
    [javac] ^
    [javac] symbol: class DefaultHttpClient
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:108: error: cannot find symbol
    [javac] HttpProtocolParams.setUseExpectContinue (params, false);
    [javac] ^
    [javac] symbol: variable HttpProtocolParams
    [javac] location: class CrashReporter
    [javac] C:\Users\blake\AppData\Local\Temp\AndE915.tmp\src\ Runtime\CrashReporter.java:111: error: cannot find symbol
    [javac] HttpResponse response;
    [javac] ^
    [javac] symbol: class HttpResponse
    [javac] location: class CrashReporter
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] 16 errors
    [javac] 3 warnings

    BUILD FAILED
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    C:\Program Files (x86)\Android\android-sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

    Total time: 5 seconds

  5. #75
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,350
    Mentioned
    44 Post(s)
    Tagged
    2 Thread(s)
    mm seems that you are using and outdated fusion build, can you updated to latest 291.6? also update you sdk tools to somethingnear to 27 or 28
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #76
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    182
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    oh... I'm using an older version because when I update it breaks a part of my main project. Which was such a bummer because I was really looking forward to flags with names. Perhaps I can run the steam version of fusion which is updated, and export from there.

    Edit: Ok jeez, sorry for bothering you I should have thought of that earlier, build worked, thank you!

  7. #77
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Sep 2017
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just wanted to say that I finally figured it out after reading dozens of forum posts. Thanks to everyone who posts helpful info. Just wish it were all in one place, explained well (and that Fusion worked with the latest versions of Java and Android SDK). I needed to install the older version of Java that someone linked to. Then I installed every API in the outdated Android SDK for every version that I wanted the app to be compatible with. That required me to switch to a different computer with a much bigger harddrive because I ran out of storage on my regular computer (it took several gigs of storage to download all the APIs). I probably installed more than I needed to, but I was sick of the error messages. After doing all that it worked. My app is in both the iOS and Android stores now. Thanks again for the help.

  8. #78
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,217
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    you don't need the older API's it's backward compatible. you can change that in Fusion under the Min and Max version, for what OS you want it to be visible. setting it to 2.3.3 and max 8.1 will give you everyone.

Page 8 of 8 FirstFirst ... 6 7 8

Similar Threads

  1. Replies: 56
    Last Post: 26th December 2017, 09:53 PM
  2. Getting build error when trying to build for Android
    By Outcast in forum Android Export Module 2.5
    Replies: 7
    Last Post: 19th March 2016, 07:10 PM
  3. Android Build Error
    By dsilvers in forum Android Export Module Version 2.0
    Replies: 21
    Last Post: 28th February 2014, 01:22 AM
  4. Android Build Error
    By dsilvers in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 2nd April 2013, 02:51 AM
  5. Trying Android again... getting error 83 on build
    By Tuna in forum Android Export Module Version 2.0
    Replies: 2
    Last Post: 20th January 2013, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •