User Tag List

Results 1 to 6 of 6

Thread: Animation Bugging Out For No Reason

  1. #1
    Clicker Fusion 2.5 DeveloperiOS Export Module
    FinalSpecimen's Avatar
    Join Date
    Oct 2011
    Location
    Boston, MA
    Posts
    121
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Animation Bugging Out For No Reason

    I have an in game menu that can be opened in any frame using Global Events. For no conceivable reason, when I open it while running the full game (doesn't happen when I just test an individual frame) certain objects display animations from other objects. I've checked my code a thousand times and even tried creating new objects and replacing them and it happens every single time. Has anyone ever experienced this? I am in a coma of frustration.

  2. #2
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,131
    Mentioned
    76 Post(s)
    Tagged
    0 Thread(s)
    So your menu code is in global events. But are all the menu objects global objects? And if so, are they identical? (I think there are two types of global objects - one type allows differences in the objects). And are those objects definitely present in every single frame?

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)
    alexexhowl's Avatar
    Join Date
    Jan 2015
    Location
    RU, YKT
    Posts
    348
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    i'm also stucked with this problems (Platformer). Some events putted on behiavours, some on global events, and levels was maked on 60+ frames. Simple on A collision with B doesn't create C, events works well on, for example, on frame №15-53-44-5-8. But doesn't work on №16-20-45-5-6-7.

    So i decided to do it only using level editor on few frames. like main menu, settings, game.

  4. #4
    Clicker Fusion 2.5 DeveloperiOS Export Module
    FinalSpecimen's Avatar
    Join Date
    Oct 2011
    Location
    Boston, MA
    Posts
    121
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've found a solution that seems to be working for the majority of the frames that use this menu - turning off "force load on call for all objects" in the frame properties. Turning off 'load on call' for individual objects also was a helpful solution. I'm a little concerned that this feature (supposed to speed up frame load time, correct?) has caused this much of a headache. I even tried removing all global events from my game and found I was still getting the same result, so I'm not quite sure what logical explanation there is for why this happened.

  5. #5
    Clicker Fusion 2.5Android Export Module

    Join Date
    Sep 2010
    Posts
    536
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I usually make all my menues in a subapp, mainly so i don't have to keep track of npc's/moving objects and never had any problems with that but maybe that's not an option?

  6. #6
    Clicker Fusion 2.5 DeveloperiOS Export Module
    FinalSpecimen's Avatar
    Join Date
    Oct 2011
    Location
    Boston, MA
    Posts
    121
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The menu is too integrated at this point to change how it actually works. This really shouldn't be happening, it's completely illogical. And it only happens some of the time, to the point where I can't recreate it at will. Is this not something anyone has ever encountered? Objects bugging out and using other object's animation frames? This has to be solved and for my own health (not joking) I can't spend any more time trying to fix it on my own. Please if there's any kind of explanation or possible future patch fix for this, I must know ASAP.

Similar Threads

  1. Active object controls and movement bugging out.
    By MaynardStaly in forum Fusion 2.5
    Replies: 5
    Last Post: 19th January 2016, 05:32 PM
  2. Simple platform movement is bugging me :(
    By King_Cool in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 17th January 2012, 01:49 PM
  3. Animation not playing for some weird Reason
    By Snooley in forum Multimedia Fusion 2 - Technical Support
    Replies: 8
    Last Post: 24th February 2009, 02:50 PM
  4. Please help, my application is bugging!
    By Iharmi in forum Multimedia Fusion 2 - Technical Support
    Replies: 12
    Last Post: 28th August 2008, 12:58 AM
  5. This has been bugging me for forever!!!
    By Skeets in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 5th May 2007, 08:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •