User Tag List

Page 4 of 22 FirstFirst ... 2 3 4 5 6 14 ... LastLast
Results 31 to 40 of 220

Thread: P3D 2.0 - out now!

  1. #31
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Oct 2007
    Location
    UK
    Posts
    305
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Looks fantastic. But seems I have the same problem as castlezero. Using: Nvidia GTX760, DX 12, 64-bit, Six-Core, 8GB, Win 10.

  2. #32
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)
    schrodinger's Avatar
    Join Date
    Nov 2014
    Posts
    3,155
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    Urgh, those hardware bugs are a real pain, you never know where they may lurk, and you can't directly test them unless they happen to your machine.

    Very sorry for the issue. I've prepared some test files and sent you and casleziro,
    hope we can quickly find the culprit and fix the issue,
    thank you very much for reporting the issue and for your cohoperation.

    I had tested personally on Win10 and DX12 so that's surely not the problem, wonder if this might be related to Nvidia cards again...

    forgot to ask if you (casleziro) have a Nvidia card too?

  3. #33
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Oct 2007
    Location
    UK
    Posts
    305
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Red face

    Cheers for the email schordinger. But I've solved my problem. Appears to be a pure doh moment on my part. I didn't copy the shaders to my steam version of Fusion.

  4. #34
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)
    schrodinger's Avatar
    Join Date
    Nov 2014
    Posts
    3,155
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    well, on the other hand this is a pure relief moment for me
    at least the issue appears to be more limited...
    thank you for reporting back, appreciate your kind help!

    (had just sent you another test btw, you can ditch that of course )

  5. #35
    Clicker

    Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Jun 2006
    Location
    Killeen, TEXAS
    Posts
    1,037
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    the compiled exe works fine; the .mfa running inside fusion (289.3 latest build) its just a black screen - however 1.x works fine both ways

  6. #36
    Clicker Fusion 2.5Fusion 2.5+ DLC
    casleziro's Avatar
    Join Date
    Mar 2013
    Location
    United States
    Posts
    643
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    My card is an AMD: ATI Mobility Radeon X1600

  7. #37
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,420
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    All's well on my machine. All of the example files work perfectly, very smooth, huge improvement on the previous version and with more options.

  8. #38
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)
    schrodinger's Avatar
    Join Date
    Nov 2014
    Posts
    3,155
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    @ danjo: thank you for these further infos.
    This is very strange, particularly because compiled examples work fine.

    So you don't even get the P3D loading screen,
    on all of the examples in the examples_pack mfa,
    and all of them immediately show a black screen and nothing else?

    That object doesn't even get any shader processing,
    and none of the examples have black frames/graphics (beside the "escape_from_NY" one), it's super odd.
    The only thing I can think of right now is the depth buffer causing issues.
    I know it does if you apply Fusion's own blending or RGB coefficient to elements with shader applied & depth buffer active -> in such cases I experienced black masks appearing of blended/RGB sprites, but they are not used at all by the engine since it does it directly through the shaders,
    and it's very unlikely you applied blend/RGB coefficient to all mfa examples you tried...
    Still more odd that compiled examples you tried (thanks) worked fine.

    If you don't mind, if/when you can,
    it could be interesting trying to remove this line from the bottom of the three
    P3D_ipm_something.xml
    and
    P3D_Skybox.xml
    shader files:

    <zbuffer>1</zbuffer>

    Then closing/reopening fusion and launching the examples.
    If it does work, it means it's the z-buffer causing issues, but you should see polygons not sorted.
    Then, if you don't mind, I'd contact you through pm for other details.
    I'm sorry for the issue you are experiencing.


    @ casleziro: thanks and thanks again for your detailed reporting,
    this is being super useful, I'm studying your captures frame by frame, hope we'll get to a solution soon.


    Meanwhile I extended testing,
    tried on a total of about 18 computers with very mixed OS/specs among relatives and friends and experienced no issues
    (didn't know if hoping to find one or not..) and so far got no other report of malfunction beside these two, very different from each other.
    I can safely say at least about 50-60 machines gave a go to the new version, so I *hope* this is quite limited at least.
    Looking around, seems like shaders, being very hardware-related and having to work on different architectures,
    can suffer from such *occasional* compatibility issues, but it has to be very sporadic,
    and usually it's some fault that gets fixed with graphics card driver updates,
    unlikely it's not been fixed by manufacturers for such old shader models used here, but who knows..

    I'm determined to find a reason and a solution, and really appreciate your help and patience.

    Anyone trying the compiled examples in this thread and/or having the engine and experiencing issues pls let me know,
    with a screenshot or even better a video capture of player hanging around,
    castle level is perfect for this with its big towers.


    @ aenever: thank you for confirming it works fine on your machine, and glad you're enjoying the new version


    Had some news to share, but I'll keep on hold while this issue isn't solved (crossing fingers), or at least clarified

  9. #39
    Clicker Fusion 2.5Fusion 2.5 Mac
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    zip2kx's Avatar
    Join Date
    Jun 2015
    Posts
    781
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    This is amazing. Please give me a piece of your brain!

  10. #40
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export Module
    Fusion 2.5 (Steam)
    schrodinger's Avatar
    Join Date
    Nov 2014
    Posts
    3,155
    Mentioned
    27 Post(s)
    Tagged
    1 Thread(s)
    Would gladly get rid of some bad circuitry in there,
    but wouldn't surely drop this crap to kind people like you

    Thank you man!

Page 4 of 22 FirstFirst ... 2 3 4 5 6 14 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •