User Tag List

Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 41

Thread: Frame rate drop since Windows update or perhaps Beta build?? Plz chime in!

  1. #1
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    197
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Frame rate drop since Windows update or perhaps Beta build?? Plz chime in!

    For the last week or so I've suddenly been noticing my game randomly go from 59-60fps to 29-30 fps for a few seconds, sometimes a prolonged period of time, and I can't find any discernible pattern. I've checked the object count and I've even monitored my code with volProfiler. I've gone backwards in versions until I know for sure it wasn't happening, and yet, it still happens; the framerate is cut in half almost perfectly.

    I'm led to believe this is either something to do with the semi-recent windows 10 update, or a bug with the recent beta builds of fusion... I was super excited for the patch with named flags, but now I'm really sad, worried, and other negative emotions... Does anyone have a similar story I NEED to get to the bottom of this.

  2. #2
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,301
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by FlipSwitchX View Post
    59-60fps to 29-30 fps
    I haven't tried the beta yet so can't comment on my experience, however those numbers suggest vsync almost certainly has something to do with it. With traditional vsync, the framerate will often be forced to go from 60 to 30. Some apps/games employ triple-buffering, which counteracts this (so you might drop gradually like this 60-58-57-54-53-49-48 for example, but not directly 60 ----> 30). I don't think Fusion has triple-buffering (I think maybe it has double buffering?), but I've never had the 60---->30 problem in Fusion myself.

    Maybe the Windows update changed your video driver settings? Open up your nvidia control panel (or AMD or Intel equivalent) and look around for anything to do with Vsync or triple-buffering and experiment with different settings. Also look at vsync settings in Fusion. Sometimes you can get 60-->30fps jumps when vsync is being forced both at the driver level and at the game level. So it's often a good idea to choose change the vsync settings in your nvidia control panel to "use the 3D application setting".

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCHTML5 Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    chrilley's Avatar
    Join Date
    Jul 2006
    Posts
    941
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    I don't know if it is related yo your issue but once I formatted my Surface Pro 3 (Windows 10) my game went from a laggy mess to smooth framerate. It should be noted that before my format I had upgraded from Windows 8 to 10 once already. Due to that I suspect there was a lot of stuff not functioning as they should. Microsoft has never been really good at upgrades so I'm worried whenever that updater starts doing its witchcraft.

    edit: Also I'm on 290.4 and has not noticed any change in performance yet. Try compare with an earlier Fusion version and see if you still have the issues though!

  4. #4
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    197
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    It seems like your right about v-sync being the problem. Unfortunately I was already using "use the 3D application setting" in nvidia. Turning v-sync off in fusion and turning it on in nvidia pales in comparison to fusions v-sync, in fact I'm not sure if it's doing anything at all. I tried turning triple buffering on via nvidia as well, possibly got worse?

    I wonder why now though... this wasn't a problem a few weeks ago... If I go backwards in fusion build, will it just erase the name data for my flags or will my .mfa even be compatible? I suppose I should ask this question in the beta build thread.

    Thanks for the input Volnaiskra.

    Thank you Chrilley. I suppose I will have to try reformatting. Perhaps first I could send some keys to beta testers and if they report the same lag then I'll really be in trouble.

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,301
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    Keep us posted. This is potentially a very worrying problem.

  6. #6
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,310
    Mentioned
    152 Post(s)
    Tagged
    2 Thread(s)
    If I go backwards in fusion build, will it just erase the name data for my flags or will my .mfa even be compatible?
    Make a copy of your MFA and test this copy with the older build, the older build will remove the flag names and initial values. Your app will still work, except that in older builds flags are set to 0 when the object is created, you'll have to initialize them manually in the event editor.

  7. #7
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    197
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    Make a copy of your MFA and test this copy with the older build, the older build will remove the flag names and initial values. Your app will still work, except that in older builds flags are set to 0 when the object is created, you'll have to initialize them manually in the event editor.
    Excellent thanks for the info.

    So far I've had 4 people test it out and they've reported the framerate is fine (phew). Since the problem seems to be on my end I'll try updating the nvidia drivers, then I'll try a previous fusion build, and if all else fails I'll reformat. Thanks for the support guys.

  8. #8
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    197
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Whoa major problem. I didn't notice at first but I believe this started happening with the v-sync/framerate issue. I can no longer change frames without a crash. When I leave on the left or the right it fades to black like it should but then crashes. I went backward to the point that I know for sure switching frames was working, and then I even set up a simple new event: Press spacebar -> jump to frame 2, and when I do this, it crashes!

    Also I just reinstalled fusion and the latest patch, I suppose I should have tried it without the patch first...

    Ok so I went backward in fusion build and switching frames work again, I guess that's why it's called beta! That's a relief... I thought this might have fixed my framerate issue as well but after playing for a minute or two it happened again.. very sad.. So I suppose I really have no option left but to reformat. At least this process has helped determined that there is something wrong with changing frame in the latest beta. I'll be back after reformatting to report on the v-sync issue, though it seems to just be my PC.

  9. #9
    Clicker Multimedia Fusion 2
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    FlipSwitchX's Avatar
    Join Date
    Feb 2012
    Location
    California
    Posts
    197
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    As luck would have it I've run out of activations on my product key. I have the steam version but I can't find the right folder to put my effects and extensions, lol....

    Captain-Picard-Facepalm.jpg

  10. #10
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator Pro
    nivram's Avatar
    Join Date
    Jul 2006
    Location
    Bandon, Oregon
    Posts
    6,731
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    The easiest thing would be to contact Clickteam direct and ask them to reset the activations.

    Marv
    ​458 TGF to CTF 2.5+ Examples and games
    http://www.castles-of-britain.com/mmf2examples.htm

Page 1 of 5 1 2 3 ... LastLast

Similar Threads

  1. iPhone 5 app frame rate drop bug [beta 8]
    By UrbanMonk in forum iOS Export Module Version 2.0
    Replies: 19
    Last Post: 13th February 2013, 10:24 AM
  2. String object frame rate drop.
    By UrbanMonk in forum iOS Export Module Version 2.0
    Replies: 8
    Last Post: 17th August 2012, 09:40 PM
  3. [Beta 32] Frame Rate, Sounds, and Lauch App
    By kiko in forum Android Export Module Version 2.0
    Replies: 19
    Last Post: 9th July 2012, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •