User Tag List

Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22

Thread: Having issues exporting, any ideas (cannot find build.xml)

  1. #11
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,128
    Mentioned
    152 Post(s)
    Tagged
    3 Thread(s)
    good to know

    may you please show me an image of your android SDK manager relating to

    Tools

    SDK Tools

    and Platform Tools
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  2. #12
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    JoshMakesGames's Avatar
    Join Date
    Jul 2016
    Posts
    108
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    android api installed.jpg

    SDK Tools installed.jpg


    Here's the Android SDK manager. If you need any more information to solve the problem, let me know.


    EDIT: When I switched over to API 17, the file built without any errors. If there's a way to get it working with build API 27, I'd like to know, but I'll settle for API 17 if I have to. I'll be checking on an Android phone as soon as I can to make sure it works correctly.

  3. #13
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,128
    Mentioned
    152 Post(s)
    Tagged
    3 Thread(s)
    ok, one thing you may only have one not all




    as you may see platform tools and build tools goes by hand, so you only need one, also i verify you may use java 9 to build but not to develop anything since android only recognize so far 6,7,8

    also i recommend these API, depending your developments, but with api 21, 24, 27 more than enough i have all them just for checking purpose on how teh runtime behave if is build using old apies

    Regards,


    Fernando Vivolo

    ... new things are coming ...

  4. #14
    Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleInstall Creator ProUnicode Add-on

    Join Date
    Jun 2011
    Posts
    628
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Google deletet ant folder from new version of android sdk tools... So users who need to use new version of tools and android studio can't use android exporter

  5. #15
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by ColdFire View Post
    Google deletet ant folder from new version of android sdk tools... So users who need to use new version of tools and android studio can't use android exporter
    They can..
    you need to have the old SDK manager separate and use that for Fusion.
    So it still is able to use the exporter!

  6. #16
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    JoshMakesGames's Avatar
    Join Date
    Jul 2016
    Posts
    108
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    So, just when I think it's done having issues, it has issues again.

    I'm not entirely sure why. It was working just fine the other day. Here's the error log. What could have changed?

    Buildfile: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\build.xml

    -set-mode-check:

    -set-debug-files:

    -check-env:
    [checkenv] Android SDK Tools Revision 25.2.5
    [checkenv] Installed at D:\Users\(my username)\AppData\Local\Android\android-sdk

    -setup:
    [echo] Project Name: RuntimeAndroid
    [gettype] Project Type: Application

    -set-debug-mode:

    -debug-obfuscation-check:

    -pre-build:

    -build-setup:
    [getbuildtools] Using latest Build Tools: 27.0.3
    [echo] Resolving Build Target for RuntimeAndroid...
    [gettarget] Project Target: Android 4.2.2
    [gettarget] API level: 17
    [echo] ----------
    [echo] Creating output directories if needed...
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin\res
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin\rsObj
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin\rsLibs
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\gen
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin\classe s
    [mkdir] Created dir: C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin\dexedL ibs
    [echo] ----------
    [echo] Resolving Dependencies for RuntimeAndroid...
    [dependency] Library dependencies:
    [dependency] No Libraries
    [dependency]
    [dependency] ------------------
    [echo] ----------
    [echo] Building Libraries with 'debug'...
    [subant] No sub-builds to iterate on

    -code-gen:
    [mergemanifest] Merging AndroidManifest files into one.
    [mergemanifest] Manifest merger disabled. Using project manifest only.
    [echo] Handling aidl files...
    [aidl] No AIDL files to compile.
    [echo] ----------
    [echo] Handling RenderScript files...
    [echo] ----------
    [echo] Handling Resources...
    [aapt] Generating resource IDs...
    [echo] ----------
    [echo] Handling BuildConfig class...
    [buildconfig] Generating BuildConfig class.

    -pre-compile:

    -compile:
    [javac] Compiling 391 source files to C:\Users\(my username)\AppData\Local\Temp\And38B.tmp\bin\classe s
    [javac] error: Source option 1.5 is no longer supported. Use 1.6 or later.
    [javac] error: Target option 1.5 is no longer supported. Use 1.6 or later.

    BUILD FAILED
    D:\Users\(my username)\AppData\Local\Android\android-sdk\tools\ant\build.xml:716: The following error occurred while executing this line:
    D:\Users\(my username)\AppData\Local\Android\android-sdk\tools\ant\build.xml:730: Compile failed; see the compiler error output for details.

    Total time: 3 seconds

  7. #17
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    1st. Use API 21+
    2nd If you use Android Studio, you need to have a separate SDK for the SDK manager.
    3rd Make sure the paths are correct in the setup from Fusion. Do NOT point to the Android Studio folders.

  8. #18
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export Module
    JoshMakesGames's Avatar
    Join Date
    Jul 2016
    Posts
    108
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Perry View Post
    1st. Use API 21+
    2nd If you use Android Studio, you need to have a separate SDK for the SDK manager.
    3rd Make sure the paths are correct in the setup from Fusion. Do NOT point to the Android Studio folders.
    Can you elaborate on what you mean by "you need to have a separate SDK for the SDK manager"?

    I'm not sure how to have a separate SDK.

  9. #19
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,334
    Mentioned
    49 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by JoshMakesGames View Post
    Can you elaborate on what you mean by "you need to have a separate SDK for the SDK manager"?

    I'm not sure how to have a separate SDK.
    In the sticky note I have the links for the sdk. Download it and install the Apis you want. Update fusion paths to that folder and your all set.

    Sent from my SM-G955U using Tapatalk

  10. #20
    Clicker Fusion 2.5Android Export ModuleiOS Export Module

    Join Date
    Jun 2015
    Posts
    73
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Just in case this is related, I recently had export issues, I found my Android exporter was not up to date eventhough my Fusion was. I would try to run Check for Updates one more time at least, and then you could try uninstall and reinstall of the Exporter from Add/Remove Programs. This solved my mysterious export problem.

    Prior to this however, we did make sure that my Fusion was pointing to the correct Android folder, which contained the BuildTools and the SDK for API 26. And my JAVA was running 1.8
    These are my directories, hope this helps:

    C:\Program Files (x86)\Java\jdk1.8.0_102
    C:\Users\Home\AppData\Local\Android\android-sdk

Page 2 of 3 FirstFirst 1 2 3 LastLast

Similar Threads

  1. multiple sample issues when exporting to android
    By VinnieG in forum Android Export Module 2.5
    Replies: 2
    Last Post: 20th January 2017, 07:49 PM
  2. Where i can find build 252?
    By GamerH2 in forum Hardware Accelerated Runtime
    Replies: 4
    Last Post: 28th December 2016, 11:50 PM
  3. issues when exporting to flash
    By hemantam in forum SWF/Flash Export Module Version 2.0
    Replies: 2
    Last Post: 5th April 2010, 06:39 PM
  4. My program won't build. Can't find old transition.
    By Neonotso in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 2nd February 2007, 10:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •