User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14

Thread: Apple Mach-O Linker Error Xcode errors

  1. #1
    Clicker Fusion 2.5Android Export ModuleiOS Export Module

    Join Date
    Jun 2015
    Posts
    40
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Apple Mach-O Linker Error Xcode errors

    Hello gang. I am attempting to build my app in Xcode but I have several Deprecation warnings and 5 errors. I've done some searching but can not find the reason. I am using Xcode 9.1, I checked my Fusion 2.5 Dev and the Check for Updates says it's updated. Any advice?

    chartboost.jpg

  2. #2
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,290
    Mentioned
    39 Post(s)
    Tagged
    2 Thread(s)
    when this happens is because you need external libs or frame work, the best way to check is get the work between quotes and google like: xcode obj-c _WKWebView that for sure will bring a result to an apple developer page, opened and search for framework, this is the framework to add in teh lib section.





    this is important to know since you will need in the near future to add this framework after adding an SDK (for e.g: admob, zbar), since in each release they may use different iOS frameworks.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  3. #3
    Clicker Fusion 2.5Android Export ModuleiOS Export Module

    Join Date
    Jun 2015
    Posts
    40
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Ah, I found it under WebView framework, imported, linked, cleaned, build, successful. I thought I got them all from Perry's list.

    Thank you!

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    Aug 2018
    Location
    Ukraine
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IOS export - xCode 9.4 failed project

    CF build 291.6. I can not build a project in xCode. xCode 9.4. When compiling a bug, about updating to target 8.0. After upgrading to 8, it issues errors that the libraries are outdated. Also, there is a problem with 64-bit.

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,290
    Mentioned
    39 Post(s)
    Tagged
    2 Thread(s)
    please publish a full log from your xcode to see what could it be worng
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #6
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,206
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by prometey View Post
    CF build 291.6. I can not build a project in xCode. xCode 9.4. When compiling a bug, about updating to target 8.0. After upgrading to 8, it issues errors that the libraries are outdated. Also, there is a problem with 64-bit.
    I can built just fine with 291.6, latest Xcode.
    Like Fernando said, post the log. you probably have some settings wrong in Xcode.

  7. #7

  8. #8
    Forum Moderator Fusion 2.5 MacFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,206
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Dont upgrade your project.
    Just change it manually to 8.0. the warnings are normal, esp. the 1st one.
    There is a setting somewhere, where you can turn 64 bit on/off, and that needs to be changed.

    I would unzip a clean copy and just change the target only.

  9. #9
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,290
    Mentioned
    39 Post(s)
    Tagged
    2 Thread(s)
    the only error i see is that you miss to set your developer account
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  10. #10
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    Aug 2018
    Location
    Ukraine
    Posts
    5
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    And what exactly did I miss in the settings of my developer account?

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Xcode errors iOS 10.3
    By Youthinkasido in forum iOS Export Module 2.5
    Replies: 1
    Last Post: 1st April 2017, 09:30 PM
  2. xCode 8 Strip Mach-O Symbols Error
    By Xeeko in forum iOS Export Module 2.5
    Replies: 0
    Last Post: 13th October 2016, 06:46 PM
  3. Xcode 5 errors - HELP
    By aenever in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 27th October 2013, 12:46 AM
  4. Xcode Errors...
    By XStar in forum iOS Export Module Version 2.0
    Replies: 25
    Last Post: 3rd September 2012, 12:45 PM
  5. Xcode Errors...
    By XStar in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 14th August 2012, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •