User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Animation sequence won't start

  1. #1
    No Products Registered

    Join Date
    Feb 2018
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Animation sequence won't start

    I've been using this tutorial (https://youtu.be/A9dz0uHu_20) to set up an engine for a game I'd like to make. However, around the 15 minute mark, I had some difficulty with getting my walking animation sequence to start. I did as instructed in the video, but the active object stays in the stopped sequence. I'm not sure what I could be doing wrong here. Thank you for any help

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Jun 2006
    Location
    St. Ave France
    Posts
    1,166
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Pay careful attention to the event that sets the animation to idle, it's likely overriding the walk animation. You really need to screen grab your events so we can see where things are going wrong.

  3. #3
    No Products Registered

    Join Date
    Feb 2018
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Click image for larger version. 

Name:	event.PNG 
Views:	22 
Size:	94.6 KB 
ID:	24763
    Click image for larger version. 

Name:	event.png 
Views:	12 
Size:	77.4 KB 
ID:	24764

    Sorry i didnt do that before, but here's what i have for the animation parts so far

  4. #4
    No Products Registered

    Join Date
    Mar 2018
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This version is good working. Hope to see the next one

  5. #5
    No Products Registered

    Join Date
    Feb 2018
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The problem is that even though this is supposed to work, no animations start..

  6. #6
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Jun 2006
    Location
    St. Ave France
    Posts
    1,166
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Actually, it's funny but a common error in your events... the problem is not that the walk animation is not starting, it's that it's RESTARTING every tick.
    You need:
    If character is on ground AND Character is moving AND current animation is NOT walking, THEN set the animation to walking.

  7. #7
    No Products Registered

    Join Date
    Feb 2018
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Click image for larger version. 

Name:	Capture2.PNG 
Views:	12 
Size:	37.8 KB 
ID:	24846

    Is this what you meant? If it was then the animation still doesn't start

  8. #8
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)

    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,421
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Since we have no clue what's behind the Green check marks, it's helpful to post the MFA
    I see nowhere in your events something about moving the animation.
    All you have it i's NOT playing..

  9. #9
    No Products Registered

    Join Date
    Feb 2018
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    sample.mfa

    Here's my file

  10. #10
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Jun 2006
    Location
    St. Ave France
    Posts
    1,166
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Ha ha ha ! Not laughing at you, just the situation. Your problem is the group you created for Animation is TURNED OFF!!! That's why the title is grey. You need to make it an active group.
    Right click, choose "Edit the actions", and then make sure it's set to be active when frame starts.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Animation sequence and counters
    By Huntermanx in forum Fusion 2.5
    Replies: 2
    Last Post: 2nd September 2016, 05:14 PM
  2. Force Animation Frame or Change Animation Sequence?
    By darkmanx_429 in forum Fusion 2.5
    Replies: 4
    Last Post: 2nd April 2014, 01:24 AM
  3. toggle animation sequence
    By arfa in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 27th August 2011, 10:41 AM
  4. Changing animation sequence
    By Rabagast in forum Multimedia Fusion 2 - Technical Support
    Replies: 12
    Last Post: 28th April 2008, 07:29 AM
  5. Animation sequence selection bug?
    By Clicktastic in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 8th September 2006, 06:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •