User Tag List

Results 1 to 5 of 5

Thread: Old built in detectors no longer working

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module
    Disthron's Avatar
    Join Date
    Sep 2007
    Posts
    244
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Old built in detectors no longer working

    Hi everyone,

    For those of you who don't remember, I released a small game back in 2013 and have been selling it on Desura and later itch.io. Anyway, I was approached by a small publisher to put my game up on Steam. They wanted me to do some small updates, Steam cards, achievements, that kind of thing. However, when I went to compile my game again the enemies stopped being animated. It seems the trick I used to create the detectors isn't working in the new version of Fusion 2.5.

    Basically, I use a fast loop to save the current animation and frame, quickly change the animation to the "detector" animation, test for collisions, then change the animation back, force the correct frame and start the animation again. I'm using "Generic Group 6" as a group for anything that has gravity and needs to colide with platformes. I took a few screen shots so you can see the code.

    I know this worked at one time because I kept all my work files form the project, and it works in the old build. I tried to downgrade my version of Fusion 2.5 but the Steam version doesn't seem to offer that feature If anyone has a solution I would really appreciate it. Is there a way to go back to previous builds? That wold probably be the simplest, otherwise if you know how to re-implement this techneque in the current version that would be helpful also.

    I'm currently on build R290.4

    Anyway, here is a composite screenshot of the code, so people can take a look.
    https://mega.nz/#!0p9lkKTI!qQsKPh1yA...FIZpjw7Ai8KmG8

  2. #2
    Clicker Fusion 2.5 DeveloperSWF Export Module
    N64Mario's Avatar
    Join Date
    Nov 2008
    Location
    USA
    Posts
    1,306
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    It would be a lot of work, but I'd say its best to re-write the code so you know what exactly got screwed up in the update to 2.5. This has happened to me and my games many many times, and got me frustrated because certain things I made worked perfectly in older MMF/CT Fusion versions, but stopped working correctly in CT 2.5. I'm not sure what the process was behind Clickteam, but whatever they "fixed" or updated to Fusion 2.5 apparently "broke" in older CT Fusion games.

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module
    Disthron's Avatar
    Join Date
    Sep 2007
    Posts
    244
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @N64Mario Oh, it was working in an earlier version of Fusion 2.5. I'm pretty sure it was working in an earlier version of the Steam version too. I've made a couple of small updates over the years. I think the last one was in 2015.

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCiOS Export ModuleInstall Creator Pro
    Julian82's Avatar
    Join Date
    May 2012
    Location
    outbuddies.com
    Posts
    922
    Mentioned
    44 Post(s)
    Tagged
    0 Thread(s)
    @Disthron : Yves made a compatibility update to get embedded detection working again. You have to tick “don’t reset frame duration” in every active object’s runtime properties that use this method (same tab as the fine detection option)

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleSWF Export Module
    Disthron's Avatar
    Join Date
    Sep 2007
    Posts
    244
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @Julian82 Thanks man, that seems to have worked really well. ^_^

Similar Threads

  1. Multi touch no longer working correctly
    By MrLambert in forum Android Export Module 2.5
    Replies: 32
    Last Post: 22nd July 2014, 03:14 PM
  2. Physics No Longer Working!
    By Jaklar in forum iOS Export Module 2.5
    Replies: 10
    Last Post: 15th January 2014, 08:45 AM
  3. Get object no longer working in flash
    By crugh in forum SWF/Flash Export Module Version 2.0
    Replies: 3
    Last Post: 11th March 2013, 02:13 PM
  4. Collision with box no longer working?
    By LobsterKing in forum Multimedia Fusion 2 - Technical Support
    Replies: 11
    Last Post: 7th January 2013, 03:25 PM
  5. LiveReceiver not working in built app
    By xerus in forum Multimedia Fusion 2 - Technical Support
    Replies: 11
    Last Post: 20th May 2008, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •