User Tag List

Results 1 to 8 of 8

Thread: PMO for enemy = stuttering?

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)HTML5 Export Module (Steam)

    Join Date
    Aug 2011
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PMO for enemy = stuttering?

    So after almost tearing my hair out trying to make some custom platform movement, i decided to use the Platform Movement Object.
    It works fine for the player and mostly for the enemy too, but i have to create a new PMO & active object for every enemy. This isn't
    really a problem though, it just takes a bit more time to do it.

    Anyway i noticed that the enemy movement stutters a bit, which is quite noticeable when scrolling and in the same direction as the player.
    The odd thing is it doesn't always stutter, it seems to change if i leave go of the movement button and then press it again. I simply have an
    enemy set up to move right when alterable A (for example) is 1, then left if it = 2. So yeah it works like it should but it stutters.

    Anyone else notice this? If you set up a simple scrolling level and have an active object move at the same or similar speed as the player, while using the PMO for the active, you should see the same.
    You should try with medium/larger size boxes as actives.

    Must be normal i guess? I tried with another active scrolling to the right using a fast loop and it seemed to be a lot smoother, though i have no clue how to do jumps/falls with fast loops and it confuses me.

    Ah well. Have a look at my file if you want, hold the right arrow button to move and look at the 2 active boxes to the right, they usually stutter, the floating one on top uses a fast loop.
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5Fusion 2.5 Mac
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    zip2kx's Avatar
    Join Date
    Jun 2015
    Posts
    780
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    I can't check right now but here's a stupid question, are you sure you have set your scrolling to one object? I've run into issues like you described but then I've had two scroling events or accidentally set it to two different objects.

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)HTML5 Export Module (Steam)

    Join Date
    Aug 2011
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by zip2kx View Post
    I can't check right now but here's a stupid question, are you sure you have set your scrolling to one object? I've run into issues like you described but then I've had two scroling events or accidentally set it to two different objects.
    Definitely not that, but there is visible stuttering on the objects themselves. Or shimmering i guess you could call it too. Thanks for your reply though.

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Perth, Australia
    Posts
    2,112
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    I'd say it's related to the fact that the enemies/player are moving at a sub pixel speed via the PMO.. like for example if an object is moving at 2.7 pixels per frame, it might not look consistently smooth compared to a whole 3 pixels per frame.

    It doesn't help that you provided an exe, it makes it impossible to really know what's going on.

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    janpier's Avatar
    Join Date
    Dec 2014
    Posts
    96
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hi, how do I know how many pixels per frame an object is moving? because I do not want to have stuttering in my game having already seen them sometimes

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)HTML5 Export Module (Steam)

    Join Date
    Aug 2011
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DaveC View Post
    I'd say it's related to the fact that the enemies/player are moving at a sub pixel speed via the PMO.. like for example if an object is moving at 2.7 pixels per frame, it might not look consistently smooth compared to a whole 3 pixels per frame.

    It doesn't help that you provided an exe, it makes it impossible to really know what's going on.
    Yeah i should have included the MFA in the first place, here's an MFA file then, i suppose it's probably related to what you are saying. In which case.. it looks like I'll be stuck with it. It could be worse i suppose as there's not much i can do about it.
    Attached files Attached files

  7. #7
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Perth, Australia
    Posts
    2,112
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    if it is a sub pixel issue, you can just try to experiment with various speeds that are compatible with the frame rate etc. do you get much stuttering in the attached?


    Also you might find it a bit cumbersome to individually create each enemy like that, you can check out this old example by... Nifflas? I think it was, also attached.
    Attached files Attached files

  8. #8
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)HTML5 Export Module (Steam)

    Join Date
    Aug 2011
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by DaveC View Post
    if it is a sub pixel issue, you can just try to experiment with various speeds that are compatible with the frame rate etc. do you get much stuttering in the attached?


    Also you might find it a bit cumbersome to individually create each enemy like that, you can check out this old example by... Nifflas? I think it was, also attached.
    Yeah that seems quite a bit better. Bit slower than i wanted but it's better, i will have to play around with the speeds a bit then. Thanks for that.

    I realise it's a bit cumbersome the way i did the enemies, but at least I'm getting results with it. I'll have to learn a couple of things in that example you attached before i can do that, if i try using that now I'll just be fighting with it.. So I'll go with what works for me at the moment.

Similar Threads

  1. Replies: 19
    Last Post: 15th November 2015, 04:35 AM
  2. My game is stuttering..
    By Aasland in forum iOS Export Module 2.5
    Replies: 4
    Last Post: 18th January 2014, 09:16 PM
  3. Problem with movement stuttering
    By Yikes in forum Multimedia Fusion 2 - Technical Support
    Replies: 12
    Last Post: 29th July 2012, 12:28 PM
  4. Frame Rate Stuttering
    By netninja in forum SWF/Flash Export Module Version 2.0
    Replies: 25
    Last Post: 6th July 2012, 01:22 PM
  5. Sound stuttering
    By Stereotype in forum Multimedia Fusion 2 - Technical Support
    Replies: 7
    Last Post: 30th January 2007, 08:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •