User Tag List

Results 1 to 3 of 3

Thread: Saving and repeatedly losing selective coding

  1. #1
    Clicker Fusion 2.5 (Steam)Android Export Module (Steam)

    Join Date
    Mar 2018
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Saving and repeatedly losing selective coding

    For some reason I keep losing ridiculous amounts of code, all tied to active objects. Backdrops haven't been affect as I'm aware.

    I DID save my progress and upon rebooting Clickteam 2.5 I've lost ALL coding tied to ALL of my active objects. Their movement types remain.

    I DIDN'T reload an old save, as all active objects are accounted for and placed in the frame. None of them have ANY code tied to them however.

    The file was originally a tutorial for 360 movement, and the objects relating to the tutorial do not interfere with the other active objects in any way. For some reason these didn't have their code deleted. They were successfully saved.

    All actives I placed have lost their coding however.

    THIS HAS HAPPENED BEFORE

    I've lost all coding around a SINGLE active object once before, fortunately I was able to reload my save. However in this case I've lost all coding around active objects I've placed.

  2. #2
    Clicker Fusion 2.5Android Export Module

    Join Date
    Sep 2010
    Posts
    568
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    This sounds really weird. I've never encountered anything like that. Do you have the latest build of fusion? Can't imagine this would happen even in older builds though. Does it happen every time you save or is it random behaviour? Do you put the code in the actual frame or in the global events?

  3. #3
    Clicker Fusion 2.5 (Steam)Android Export Module (Steam)

    Join Date
    Mar 2018
    Posts
    13
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've actually figured out what's causing the problem, and how to work around it. The main problem is impatience and a slow PC.

    After saving and shutting down my computer I'm assuming that fusion isn't given time to properly save all the new changes (As I've never experienced the problem with small programs, even when TRYING to corrupt them). I think I'm cutting it off of the process before it's done in the background, which would explain why objects are saved and not their code. This can be easily avoided by waiting a few minutes or reopening the file after saving to "lock in" the save.

    Sorry for the annoyance!

Similar Threads

  1. Saving and repeatedly losing selective coding
    By AlliterationAddiction in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 5th April 2018, 01:22 AM
  2. Replies: 4
    Last Post: 17th December 2017, 03:36 AM
  3. Selective saturation
    By TreyM in forum Hardware Accelerated Runtime
    Replies: 10
    Last Post: 4th March 2013, 11:52 PM
  4. Erreur windows selective...
    By Calimero in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 17th November 2007, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •