User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12

Thread: Has the PMO been broken?

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Oct 2006
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Has the PMO been broken?

    Ok guys, I have literally spent hours of my time trying to track this down and I've come to the conclusion that it's got to be a fusion error.

    https://www.dropbox.com/s/ujs0le54dn...leFed.mfa?dl=0

    So the PMO breaks sometimes. While jumping and changing direction in the air, it just sometimes...doesn't. It doesn't even register the arrow key press (The corresponding on screen direction will NOT light up). It's like the fusion runtime is just losing keypresses. Play around with the mfa above to see what I mean. I've pared this down to like 30 events from ~2000. It actually happens in the android runtime too. It only seems to happen during changing directions in the air. There's nothing in my code that would cause this from what I can see.

    https://www.youtube.com/watch?v=MppA_BjcL2I&t=625s about 10 minutes in it starts happening to me there as well, this was recorded live on my android phone.

    Seriously, what is going on here? This is the 3RD project now that has had unfathomable errors (The first was fine collision errors). It seriously seems like fusion 2.5 is starting to get progressively worse with each build, more and more errors.

    Any help would be greatly appreciated. I'm pulling out what little hair I have left.

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    I’m not home to check your mfa, yet on PC it could be your keyboard. I had to update to a gaming keyboard because of similar issues and all was fixed. Seems some keyboards can’t handle multiple and quick reposes. If others can’t replicate your issue, I’d say it’s time to upgrade. As for Android, I find it behaves very differently to the windows environment, I suggest trial and error until you find a solution. If you can isolate the problem perhaps use the bug box.

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Oct 2006
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am absolutely 100% sure it is not the keyboard.

  4. #4
    Clicker

    Fusion 2.5Android Export Module

    Join Date
    Jan 2007
    Posts
    259
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    Does your keyboard have no key rollover? Probably not - still possibly keyboard.

    The video doesn't show us anything. For all we know your digitizer on your screen (if that's actual phone gameplay) could be screwed up. You have to want to be helped to get help and assuring us that "I am absolutely 100% sure it is not the keyboard." without providing an explanation of how you came to that conclusion tells us nothing and gets us nowhere.

  5. #5
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Oct 2006
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I guess you didn't actually try the mfa. When you press either right or left, the on screen direction indicator will light up. There is no rollover problem because it only fails like once in 25 jumps when you change direction in mid air. Ive tested this well over 50 times and I can definitively say it's not an overrun problem. The issues further appear in the Android runtime (despite having no keyboard controls). Both the keyboard condition and the touchscreen condition run the same event on the PMO object. It simply doesn't trigger. That's what makes me think there's something going on with the PMO.

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCUnicode Add-on

    Join Date
    Jan 2009
    Location
    FRANCE
    Posts
    148
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Hello,
    I never had this problem with PMO (and still don't have).
    I'm not an Android / Ouya user (required extensions), so I unfortunately can't test your mfa.

  7. #7
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    I checked your MFA on windows, now that I'm home. I honestly couldn't get it to glitch as your describing. It worked as it should with multiple left and right quick movements - with and without jumping.

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export ModuleSWF Export Module

    Join Date
    Oct 2006
    Posts
    270
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Then I guess it's reinstall time.

  9. #9
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    You can delete the PMO and reinstall it rather than a full reinstall of Fusion, good luck. Let us know if it was the issue.

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleXNA Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    piscesdreams's Avatar
    Join Date
    Dec 2007
    Location
    United States
    Posts
    928
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I couldn't get the bug to happen using my keyboard either. All worked as it should.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. broken app help, please
    By gagegage926 in forum Fusion 2.5
    Replies: 0
    Last Post: 30th April 2014, 08:40 PM
  2. Layers 5+ Broken?
    By Hazzow in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 28th December 2012, 03:37 PM
  3. CharImage [Broken]
    By Danny in forum Multimedia Fusion 2 - Technical Support
    Replies: 30
    Last Post: 19th December 2011, 03:23 PM
  4. This is broken.
    By Corlen in forum File Archive
    Replies: 10
    Last Post: 9th August 2009, 08:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •