User Tag List

Results 1 to 2 of 2

Thread: [Bug] Upscaling doesn't work correctly with Direct3D 9

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleSWF Export Module

    Join Date
    Apr 2007
    Posts
    208
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    [Bug] Upscaling doesn't work correctly with Direct3D 9

    I'm aware this is supposed to go in the bugbox, but it is currently down.

    Suppose I wish to do a pixel-perfect upscale of a game (say 1px is rendered as 3px) I can do this ok in software and Direct3D 8, but there is a rendering bug in Direct3D 9. Something about the upscaling seems to stretch the image. Interestingly I noticed that this upscaling bug also happens for sub-applications but not when scaling sprites.

    I've attached a simple reproduction to illustrate the issue. I have yet to come up with a suitable workaround.
    Images attachées Images attachées
    Attached files Attached files

  2. #2
    Clicker Fusion 2.5 DeveloperSWF Export Module
    N64Mario's Avatar
    Join Date
    Nov 2008
    Location
    USA
    Posts
    1,306
    Mentioned
    15 Post(s)
    Tagged
    0 Thread(s)
    Yea I noticed this too... I figured it was a graphics thing (as the way they are handled being drawn) that Direct 9 has odd stretch behaviors. If it really is a bug, that would be interesting.

    That's why I just switched to Direct 8 for pixel perfect sprite scaling for my classic/retro games.

Similar Threads

  1. Replies: 3
    Last Post: 30th August 2018, 11:52 AM
  2. FGL doesn't work/link correctly
    By Hydra in forum Flash Export Module 2.5
    Replies: 2
    Last Post: 16th September 2015, 07:27 AM
  3. Back button doesn't work correctly
    By AndyH in forum Android Export Module Version 2.0
    Replies: 0
    Last Post: 11th May 2013, 09:10 AM
  4. Overlay Redux pasting doesn't work correctly?
    By alspal in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 16th August 2012, 08:40 AM
  5. [Bug]Edit Box doesn't work correctly in SubApp
    By Jacob in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 4th October 2009, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •