User Tag List

Results 1 to 8 of 8

Thread: 3D models randomly shift around when new ones are added to the engine

  1. #1
    Clicker
    Quote's Avatar
    Join Date
    Mar 2015
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question 3D models randomly shift around when new ones are added to the engine

    I just recently started having this issue where models would randomly shift around by a little bit every time a new one was added, including when they are loaded in at the start of the frame. I can't tell what I did to cause this issue, as it just randomly started sometime last week. Has anyone else been having this issue?

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Jan 2016
    Posts
    374
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    i would guess its a scoping issue - normal scoping rules dont really apply to firefly - so if your moving them on creation - your scoping a different one to the one you think you are

  3. #3
    Clicker
    Quote's Avatar
    Join Date
    Mar 2015
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    How would I go about fixing that?

  4. #4
    Clicker Fusion 2.5 DeveloperAndroid Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Jan 2016
    Posts
    374
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Different ways depending on what your doing but

    create an object
    if object flag 0 = off -> set location x,y,z -> set flag 0 = true

    that way your only moving an object you have never moved before

    you could even use an alt val instead of a flag and set that to a creation number so you can move it again afterwards

  5. #5
    Clicker
    Quote's Avatar
    Join Date
    Mar 2015
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I tried using the flag method, but it resulted in the same thing happening.
    Oy.jpg

  6. #6
    Clicker
    Quote's Avatar
    Join Date
    Mar 2015
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If it's any help, the method I'm using to position objects in 3D is to set the XY position of the model to the XY position of a 2D object, and I think the visual glitching is caused by the models not knowing which position to jump to.

  7. #7
    Clicker
    Quote's Avatar
    Join Date
    Mar 2015
    Posts
    20
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Alright, I found out what was wrong. Apparently it wasn't an issue with the scoping, but rather an issue with the clipping. All I had to do to fix it was change the Near Clipping Plane value on the camera to 100.

  8. #8
    Clicker Fusion 2.5 DeveloperAndroid Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Jan 2016
    Posts
    374
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    hmmm changing near clip would only hide stuff right next to your camera...

Similar Threads

  1. Replies: 15
    Last Post: 11th January 2017, 04:45 PM
  2. 3D Models
    By Jack_Mcphee in forum Multimedia Fusion 2 - Technical Support
    Replies: 9
    Last Post: 2nd March 2009, 01:23 PM
  3. The randomly crashing atmospheres engine
    By Nifflas in forum Multimedia Fusion 2 - Technical Support
    Replies: 15
    Last Post: 15th October 2006, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •