User Tag List

Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18

Thread: Lexical or Preprocessor Issue - ios 12 issue (Xcode 10.0)

  1. #11
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    977
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    @Perry - hey, don't judge me! I'm on the latest build

    I had to be to address the problem apple gave me with their newest iOS which almost crippled me!!! I'm still reeling

  2. #12
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleMac Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,372
    Mentioned
    57 Post(s)
    Tagged
    0 Thread(s)
    LOL. It seemed that I had to upgrade to the latest Xcode.. Thought Apple wouldn't accept old Xcode versions anymore, but sounds like what @Fernando said that there are still people out there.
    Really thought it was a Mandatory thing.
    @SHINBAXTER I'm not afraid of you... LOL

  3. #13
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    977
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    @Perry you will be....my time of conquest is rapidly approaching

  4. #14
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,313
    Mentioned
    203 Post(s)
    Tagged
    4 Thread(s)
    Next build this will be changed.

    but hey you can change , tips always follow the change recommendation when you move from one version of xcode to another

    there is a nasty bug in xcode though test yourself

    open any extension you may do in .h or .m and trying to type a new import tell me if does crash for you or not

    example:

    #import "CObjectCommon.h" but typing not cut and paste
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  5. #15
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    977
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    did not crash for me, altho I don't know if I did it right as I'm not good at Xcode.

    in my CRunMultipleTouch.m file

    I typed in your "CObjectCommon.h" line on line 25 like this.....

    ------
    * FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
    * IN THE SOFTWARE.
    */
    //----------------------------------------------------------------------------------
    //
    // CRUNMultipleTOuch
    //
    //----------------------------------------------------------------------------------
    #import "CObjectCommon.h"
    #import "CFile.h"
    #import "CRunApp.h"
    #import "CBitmap.h"

    -------


    dunno if thats right, but it ran fine with no crashing.

    p.s. on a side note, there was a crashing bug with the IAP on iOS. on bugbox you uploaded a file that bug poster user said fixed it, but the bugbox closed just before I could download the file to check it myself will that fix be included in the next fusion build update?

  6. #16
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    977
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    oh & i'm running Xcode Version 10.0 (10A255) on MacOS High Sierra version 10.13.6 (17G65)

  7. #17
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,313
    Mentioned
    203 Post(s)
    Tagged
    4 Thread(s)
    mm weird i am using 10.0 and mojave

    and it seems to close the xcode doe snot happens often in beta 10.1 but something is missing that after few hours xcode start not to recognize my device aneed to restart my mac.

    i will send by PM the iAPStore code for you to try
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  8. #18
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    977
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    I have found tho that since I updated to xcode 10.0 sometimes I have had some random crashes, especially when I try to archive a build for submission. maybe something is buggy with Xcode build 10.0

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Lexical or Preprocessor Issue - ios 12 issue (Xcode 10.0)
    By iamjot in forum Mac Export Module & Fusion MAC Editor
    Replies: 0
    Last Post: 4th October 2018, 02:30 PM
  2. Semantic issue in Xcode
    By iamjot in forum iOS Export Module 2.5
    Replies: 8
    Last Post: 21st February 2014, 06:23 PM
  3. compile issue in xcode
    By Deathkiller in forum iOS Export Module Version 2.0
    Replies: 2
    Last Post: 2nd October 2012, 03:04 PM
  4. Issue in XCode
    By Captain_Harris in forum iOS Export Module Version 2.0
    Replies: 3
    Last Post: 2nd April 2012, 10:53 AM
  5. XCode 4 Issue
    By RhysD in forum iOS Export Module Version 2.0
    Replies: 8
    Last Post: 14th March 2011, 02:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •