User Tag List

Results 1 to 5 of 5

Thread: Webview and Ajax requests do not work

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module

    Join Date
    Sep 2006
    Location
    UK
    Posts
    842
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Webview and Ajax requests do not work

    HI, I will post this in the bug tracker once its back up online.

    What I am finding is the follow, if you load a HTML page up which uses the Jquery Ajax / POST / GET request they do not work on iOS.

    I have done some googling and it appears there was a bug with the iOS web view kit which got fixed so I was wondering if there anything can be done.

    This is a real imperative feature as it obviously makes for smooth UI experiences in apps.

    Thanks
    Andy

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module

    Join Date
    Sep 2006
    Location
    UK
    Posts
    842
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Just to add to this. After more testing, JS AJAX / $.POST requests work fine if you navigate to the URL directly from MMF.

    If however you "load HTML' with a $.POST request, it does not work.

    Even if you load a HTML file which contains some PHP with a header redirect to the page with the JS AJAX / POST request it still doesn't work.

    Thanks
    Andy

  3. #3
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,128
    Mentioned
    152 Post(s)
    Tagged
    3 Thread(s)
    mm I have users running php and seems to be working OK, please add a small mfa for me to check
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module

    Join Date
    Sep 2006
    Location
    UK
    Posts
    842
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I will put together an mfa to show. However php does work fine, I am using it within my app. The issue I am finding is when a page (php or static html) that uses the Jquery Ajax functionality it only works if you use the ‘go to url’ action.

    If you ‘load html’ Jquery Ajax doesn’t work, or if you load HTML which redirects you to the page on a web server the Jquery Ajax still fails.

    Andy

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,128
    Mentioned
    152 Post(s)
    Tagged
    3 Thread(s)
    oh now i understand
    if you are using in your page something like this

    <script src="jquery-3.3.1.min.js"></script>

    it won't work

    di you try to install in your server and do a remote call
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Similar Threads

  1. webview on ios
    By Chokito in forum iOS Export Module 2.5
    Replies: 16
    Last Post: 13th September 2016, 08:19 PM
  2. Webview
    By kiko in forum iOS Extensions
    Replies: 1
    Last Post: 17th July 2013, 03:16 PM
  3. Some requests for the editor
    By Atom in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 29th June 2012, 01:35 AM
  4. a few requests!!!
    By cel in forum Extension Development
    Replies: 3
    Last Post: 31st March 2008, 07:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •