User Tag List

Results 1 to 4 of 4

Thread: Animation Error Please Help

  1. #1
    No Products Registered

    Join Date
    Nov 2018
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Animation Error Please Help

    When my character moves to the right the animation is fine, but when he moves left, the walking Sprite moves backwards by a few pixels, the hotspot and action point for him are the same on both the right and left so I don't know why it's doing this. However it seems to happen whenever I copy and paste the right animations to the left, hopefully this is enough information for this to get fixed.

  2. #2
    No Products Registered

    Join Date
    Nov 2018
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    https://youtu.be/qSO9s6WXz_8
    Here is a clip of it

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,438
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    I tend to leave my hotspot to the top left. Then when I cut and paste the right to the left or vice versa I flip the animation yet keep the hotspot to the left. It always works for me. If you've done that and it's still not working your animation probably isn't centered. If that's the case center it in an art program or adjust your hotspot to the exact center of your sprite. If you post your animation on a simple mfa I can show you if you can't work it out

    To be honest the error in your video isn't very obvious yet if it bugs you, I can help.

  4. #4
    No Products Registered

    Join Date
    Nov 2018
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That worked! Thank you so much!

Similar Threads

  1. Replies: 11
    Last Post: 15th March 2014, 06:22 AM
  2. Change Animation Sequence Error
    By Gate001 in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 29th February 2012, 07:38 AM
  3. "Load Frame into animation"-error, compiled progr.
    By Peer3000 in forum The Games Factory 2 - Technical Support
    Replies: 4
    Last Post: 21st April 2010, 08:05 PM
  4. [BUG] Animation object- Runtime Error!
    By aidmm in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 23rd January 2007, 11:02 PM
  5. Error with mmf1-game: extension load error in mmf2
    By Quinto in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 27th November 2006, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •