User Tag List

Results 1 to 5 of 5

Thread: [BUG]Playing and finished of the animation were not triggered

  1. #1
    Clicker

    Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleXNA Export ModuleUnicode Add-on
    Fusion 2.5 (Steam)
    ASD's Avatar
    Join Date
    Feb 2007
    Location
    Japan
    Posts
    1,764
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)

    Exclamation [BUG]Playing and finished of the animation were not triggered

    Conditions of the animation "Playing" and "Finished" were not triggered if speed of animation changed by event.

    Happened in Build 291.6

    change_animation_speed_bug_b291_6.mfa

  2. #2
    Clicker Fusion 2.5Fusion 2.5+ DLC

    Join Date
    Jun 2006
    Posts
    888
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seems like something went wrong with animations. I have raised another bug an hour ago - switching to a non-looped animation quickly and repeatedly causes it to freeze on its last frame.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    Blizna is right it's the same bug yet there is a way to work around it. Here's my example fix. I know it would be great if these problems didn't happen yet there is often a way around them.

    By the way changing the animation to stopped after creation seems important, as well as setting the speed to zero in the animation (if the animation speed is set in the active, it doesn't change to the counter speed unless it's on zero). Go figure?

    change_animation_speed_bug_b291_6 work around.mfa

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Diogen's Avatar
    Join Date
    Feb 2016
    Location
    Zaporizhzhya, Ukraine
    Posts
    47
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Don't use Stopped animation in this example. Use any other...

    change_animation_speed_bug_b291_6_walking_anim.mfa

  5. #5
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export Module
    aenever's Avatar
    Join Date
    Jun 2013
    Posts
    1,436
    Mentioned
    14 Post(s)
    Tagged
    0 Thread(s)
    You'll still need to change the animation speed inside the active to zero. Otherwise when I tested your file and set the counter to zero it still played the animation. An animation speed of zero should not play the animation past the first frame.

Similar Threads

  1. Replies: 4
    Last Post: 27th January 2018, 08:31 PM
  2. "Has sample finished playing" during loop? (fixed)
    By Ambidextroid in forum Fusion 2.5
    Replies: 0
    Last Post: 19th November 2016, 02:47 AM
  3. Animation does not disappear when finished
    By cathy_1966 in forum Fusion 2.5
    Replies: 14
    Last Post: 25th October 2016, 10:25 PM
  4. Replies: 5
    Last Post: 9th June 2016, 11:37 AM
  5. When animation is over event not being triggered
    By FateForWindows in forum Fusion 2.5
    Replies: 13
    Last Post: 17th July 2015, 11:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •