User Tag List

Results 1 to 4 of 4

Thread: Google play requires API 26+

  1. #1
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    SpaceKoala's Avatar
    Join Date
    Jan 2019
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Google play requires API 26+

    Hi,

    I've googled and followed numerous tutorials on how to setup android sdk for the android exporter, and I can export my app for personal use on my phone with no problem, but when I try to upload my app to Google Play it gives the error "Your app currently targets API level 9 and must target at least API level 26 to ensure that it is built on the latest APIs optimised for security and performance. Change your app's target API level to at least 26."

    helpapi.jpg

    I should be up to date (see below) but in Fusion under Android Options/Build API, when I click newest installed SDK API it picks 21 (typing in 26 doesn't fix the problem either.

    andsdk1.jpg

    Has anyone else run into this problem?

  2. #2
    Clicker Fusion 2.5 Mac
    Fusion 2.5 (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)
    retrobruno's Avatar
    Join Date
    Dec 2018
    Location
    Somewhere in time
    Posts
    12
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hello,

    Have you set the API 28 to you Android project in Fusion 2.5 ?
    API28.jpg

  3. #3
    Clickteam Clickteam
    Olivier's Avatar
    Join Date
    Jun 2006
    Posts
    3,000
    Mentioned
    9 Post(s)
    Tagged
    1 Thread(s)
    To slove this issue you have to set the property Target Android version to 8.0 which matches API level 26.

    From August 1, 2018, Google requires that every app targets at least API level 26:
    https://developer.android.com/distri...lop/target-sdk

    You can find which Android version matches which API level on this page:
    https://developer.android.com/about/dashboards/


    I think that there's some confusion between the various SDK versions, which is quite understandable, so let me shed some light.

    Build API = the API Level that the application is complied with = compileSdkVersion
    Minimum Android version = the minimum API Level required for the application to run = minSdkVersion
    Target Android version = the API Level that the application is tested against = targetSdkVersion

    The Build API property is always set to the latest SDK version aka API Level installed by the Android SDK Manager. For example, in the attached screenshot, it is API Level 28:

    android-sdk-manager.png

    Finally, here are some useful links to help you understand the difference between the various SDK versions:
    https://developer.android.com/guide/...es-sdk-element
    https://medium.com/androiddevelopers...n-a098a0341ebd
    https://www.dummies.com/web-design-d...-sdk-versions/

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    SpaceKoala's Avatar
    Join Date
    Jan 2019
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for that guys. I seem to have compiled something that the google play store will accept.

    (It kept changing the API build back to 21 until I uninstalled that API!)

Similar Threads

  1. Replies: 3
    Last Post: 24th May 2016, 02:18 PM
  2. Google play not accepting my app.
    By District in forum Android Export Module 2.5
    Replies: 1
    Last Post: 2nd June 2015, 05:58 AM
  3. Google Play question?
    By KLiK-iT in forum Android Export Module 2.5
    Replies: 2
    Last Post: 1st August 2014, 03:50 PM
  4. google play...
    By Sevennemesis in forum Android Export Module Version 2.0
    Replies: 3
    Last Post: 15th June 2012, 03:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •