User Tag List

Results 1 to 2 of 2

Thread: [Bug] "Resume all sounds" plays previously loaded sounds in an uncontrollable state.

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleUniversal Windows Platform Export Module

    Join Date
    May 2014
    Posts
    97
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)

    [Bug] "Resume all sounds" plays previously loaded sounds in an uncontrollable state.

    This is a weird one.

    The first time you enter the music frame, everything is fine. The second time you enter it, it will play the same file twice, but only one instance can be controlled. Even with "Play sounds over frames" disabled, the uncontrollable instance will follow you from frame to frame. This is caused by the "Resume all sounds" action in event 6 of the second frame.

    Unticking "Load all data at start" eliminates the problem, but obviously results in slower load times.

    This does not happen on the Windows and Android runtimes. Tested on XB1 with different target versions and different VS2017 versions. Fusion version is 291.6.

    I'll be looking for a workaround soon, but this really is a problem.

    MFA: https://mega.nz/#!3jxyGIaa!6O01ZJJde...st4ZfwNDFIBd-A

  2. #2
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleUniversal Windows Platform Export Module

    Join Date
    May 2014
    Posts
    97
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Here is a workaround: "Is channel X paused?" is added to the culprit event.

    For whatever reason, UWP doesn't like "Resume all sounds" the first time it runs through the events.

    MFA: https://mega.nz/#!O7B2BKSA!UvQZNIimZ...L_nROjsAqPlzXE

Similar Threads

  1. Replies: 4
    Last Post: 9th October 2016, 11:10 AM
  2. Sounds not played if I choosed "Play from disk" option
    By ASD in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 6th September 2013, 03:56 PM
  3. "Resume all sounds" doesn't resume, it restarts
    By JoKa in forum iOS Export Module Version 2.0
    Replies: 0
    Last Post: 7th March 2012, 12:56 PM
  4. RC #1 - Bug - Sounds + App Resume + Question
    By BHGames in forum iOS Export Module Version 2.0
    Replies: 19
    Last Post: 7th June 2011, 04:24 PM
  5. No "sounds over frames" & "Stop sample" crash
    By Giovanni_Cardona in forum iOS Export Module Version 2.0
    Replies: 1
    Last Post: 5th November 2010, 01:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •