User Tag List

Page 24 of 24 FirstFirst ... 14 22 23 24
Results 231 to 238 of 238

Thread: Android Runtime - Build 292

  1. #231
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCiOS Export ModuleMac Export ModuleInstall Creator ProPatch Maker
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Oct 2012
    Posts
    274
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    I'm having trouble building apk. I've read the requirements, the installation that is needed and so far I ended up with:

    Android/Ouya application

    com.sevensails.testclick
    Build API 29
    minimum : 4.0/4.0.1/4.0.2
    Target Android 10 (I tested 8 also, no luck)

    In Preferences-General I defined the path of JDK

    Program Files\Java\jdk-14.0.1

    I installed the Android Studio and set the SDK to there:
    Appdata\Local\Android\SDK

    I'm getting the following message:


    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not initialize class org.codehaus.groovy.runtime.InvokerHelper

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    BUILD FAILED in 0s

  2. #232
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCiOS Export ModuleMac Export ModuleInstall Creator ProPatch Maker
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Oct 2012
    Posts
    274
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by SevenSails View Post
    I'm having trouble building apk. I've read the requirements, the installation that is needed and so far I ended up with:

    Android/Ouya application

    com.sevensails.testclick
    Build API 29
    minimum : 4.0/4.0.1/4.0.2
    Target Android 10 (I tested 8 also, no luck)

    In Preferences-General I defined the path of JDK

    Program Files\Java\jdk-14.0.1

    I installed the Android Studio and set the SDK to there:
    Appdata\Local\Android\SDK

    I'm getting the following message:


    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not initialize class org.codehaus.groovy.runtime.InvokerHelper

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    BUILD FAILED in 0s
    Found the problem, changed the JDK directory to the one in Android Studio
    C:\Program Files\Android\Android Studio\jre

  3. #233
    Forum Moderator Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Patrice's Avatar
    Join Date
    Sep 2010
    Posts
    585
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Hi android compilation fail with update 292.26, anyone has same problem ?


    > Configure project :app
    WARNING: The option 'android.useDeprecatedNdk' is deprecated.
    The current default is 'false'.
    It has been removed from the current version of the Android Gradle plugin.
    NdkCompile is no longer supported
    Checking the license for package Android SDK Build-Tools 29.0.2 in C:\Users\Patrice\AppData\Local\Android\Sdk\license s
    Warning: License for package Android SDK Build-Tools 29.0.2 not accepted.
    Checking the license for package Android SDK Platform 29 in C:\Users\Patrice\AppData\Local\Android\Sdk\license s
    Warning: License for package Android SDK Platform 29 not accepted.

    FAILURE: Build failed with an exception.

    * What went wrong:
    Could not determine the dependencies of task ':app:compileDebugJavaWithJavac'.
    > Failed to install the following Android SDK packages as some licences have not been accepted.
    build-tools;29.0.2 Android SDK Build-Tools 29.0.2
    platforms;android-29 Android SDK Platform 29
    To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
    Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html

    Using Android SDK: C:\Users\Patrice\AppData\Local\Android\Sdk

    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

    * Get more help at https://help.gradle.org

    BUILD FAILED in 1s

  4. #234
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,383
    Mentioned
    58 Post(s)
    Tagged
    0 Thread(s)
    you need to accept the license.

    try this


    cd /d "%ANDROID_SDK_ROOT%/tools/bin"
    Run the sdkmanager as follows:

    sdkmanager --licenses

  5. #235
    Forum Moderator Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Patrice's Avatar
    Join Date
    Sep 2010
    Posts
    585
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Not working, launching Android studio but cannot find where accepting licence...

  6. #236
    Forum Moderator Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Patrice's Avatar
    Join Date
    Sep 2010
    Posts
    585
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Ok, it's works, must dw 29.0, 29.01 and 29.02 API construction in Android Studio. Last build automaticly target it on Fusion properties.
    Thx for your help

  7. #237
    Forum Moderator

    Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleMac Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)
    Perry's Avatar
    Join Date
    Dec 2013
    Location
    Watertown, WI
    Posts
    4,383
    Mentioned
    58 Post(s)
    Tagged
    0 Thread(s)
    Glad I could help

  8. #238
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)
    GKProduction's Avatar
    Join Date
    Aug 2017
    Location
    Russia, Kostroma
    Posts
    90
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Bug with 2DBox in Android runtime

    If you use the action (at Physic - Engine): World -> Add Object, but this object is not added to the frame, then the application will crash (not always). This event I have in behavior, and I adding objects via qualifier.

Page 24 of 24 FirstFirst ... 14 22 23 24

Similar Threads

  1. Users that cannot build with Android Studio (ant\build.xml error)
    By Perry in forum Android Export Module 2.5
    Replies: 102
    Last Post: 28th November 2019, 07:02 PM
  2. Replies: 56
    Last Post: 26th December 2017, 08:53 PM
  3. Cannot build my Android app (ant/build.xml error)
    By oaklan5 in forum Fusion 2.5
    Replies: 1
    Last Post: 27th July 2017, 06:59 PM
  4. Replies: 15
    Last Post: 27th November 2014, 10:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •