User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16

Thread: Weird sound glitch at the end of audio clips

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Lukiester's Avatar
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Weird sound glitch at the end of audio clips

    Hello there, i am working with numerous audio files and a few of them seem to produce a weird audio glitch. When the audio finishes, another sound plays, some static sound. It's not to do with my programming because it occurs in the data elements tab when i simply play the audio. I have attached a couple of samples, of course this glitch does not occur naturally in the audio files.

    I can fix this problem by re-exporting these audio files but i was just wondering if there is another fix.

    https://www.mediafire.com/file/f23nb...litch.m4a/file

    Thanks so much for the help, Lucas.

  2. #2
    Clicker Fusion 2.5 Mac
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Jan 2015
    Location
    Australia
    Posts
    151
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    There's an option under the application properties for "Optimise 'Play Sample'" - I think I remember someone in another thread mentioning turning this off in case of audio issues.

    Otherwise, it might be easier to isolate what's going on with a sample MFA with the sounds embedded in them (I'm guessing the m4a file is recorded from playback in Fusion and not the embedded audio file itself)

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Lukiester's Avatar
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi there, thanks for the reply. I can't seem to find that, don't know if im just being stupid, i have found "compress sounds"?? But that is unchecked.
    I have tried that, it must be something in the audio files themselves.

    Thank you.

  4. #4
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    2,997
    Mentioned
    19 Post(s)
    Tagged
    2 Thread(s)
    The Optimise Samples property is part of 2.5+ DLC.

    If you open the files up in an audio editor, you can see they contain the glitches you hear. This isn't a Fusion issue. You will need to edit these out yourself...



    Also, how are you playing these? With Fusion's native sound component? As it's an m4a and not an mp3...
    Want to learn Clickteam Fusion 2.5?




  5. #5
    Clicker Fusion 2.5 Mac
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Jan 2015
    Location
    Australia
    Posts
    151
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    I was wondering that myself originally - I'm assuming the m4a is a recording of the issue happening in Fusion (across two samples) and not the original sound files themselves

  6. #6
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    2,997
    Mentioned
    19 Post(s)
    Tagged
    2 Thread(s)
    Oh I see... Haha thought it was a bit strange there were multiple effects in one. Might be best to post the source audio files to check (and test)
    Want to learn Clickteam Fusion 2.5?




  7. #7
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Lukiester's Avatar
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Hi, thanks, the source files contain no glitches, i can guarantee that. This was an audio recording i just recorded manually by playing all the audio files in the data elements menu. I have attached a fusion file that contains an audio file with the glitch. The best way to show off the bug is playing the sound file in fusion. Then extracting the audio file and playing the audio outside fusion.
    Attachment 27177

    Thanks, Lucas.

  8. #8
    Clickteam Clickteam
    Danny's Avatar
    Join Date
    Aug 2007
    Location
    United Kingdom
    Posts
    2,997
    Mentioned
    19 Post(s)
    Tagged
    2 Thread(s)
    Hey Lucas,

    Yes I see the issue now. If you downsample to 16-bit instead of using 24 bits, it works correctly. I will take a look into why 24 bit seems to struggle.
    Want to learn Clickteam Fusion 2.5?




  9. #9
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Lukiester's Avatar
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks a lot. I think all my sounds are 24bit and most seem to be working, ill check with my sound man.

  10. #10
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Lukiester's Avatar
    Join Date
    Feb 2014
    Location
    Melbourne
    Posts
    363
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Yeah there all 24bit, it is weird that only some audio files are causing the problem. I might submit the mfa to the bug tracker.

    Thanks.

Page 1 of 2 1 2 LastLast

Similar Threads

  1. AUDIO Experienced Sound Designer/Composer Looking for Work: ANY STYLE, ANY SOUND
    By Matthewdeargameaudio in forum Paid Design & Development Requests
    Replies: 88
    Last Post: 27th August 2017, 04:12 PM
  2. Play from a random library of sound clips
    By soopytwist in forum Multimedia Fusion 2 - Technical Support
    Replies: 11
    Last Post: 18th May 2015, 06:18 PM
  3. audio clips truncated?
    By brett in forum Fusion 2.5
    Replies: 5
    Last Post: 29th January 2014, 05:09 PM
  4. Weird Sound Card Beeping - Sound Player Extension
    By xmetalxthrasherx in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 12th July 2011, 06:09 AM
  5. Another weird glitch
    By maestro1 in forum File Archive
    Replies: 2
    Last Post: 16th April 2008, 01:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •