User Tag List

Page 3 of 11 FirstFirst 1 2 3 4 5 ... LastLast
Results 21 to 30 of 104

Thread: Build 292.5 - Release version

  1. #21
    Forum Moderator Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module
    AndyH's Avatar
    Join Date
    Jun 2006
    Location
    UK
    Posts
    1,444
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Found a small bug with Qualifiers, tested in Event Behaviours. The qualifier of another object will disappear after editing an action if the qualifier has no actions, and it cannot be added back in until close and re-open the behaviour editor.

    Steps to reproduce:

    1. Create two active objects.
    2. Create an event behaviour on the first.
    3. Add the Neutral qualifier on the second.
    4. Open the event behaviour of the first and create an event with an action to set alterable value to 0.
    5. Using the event headings (import new objects), bring in the Neutral qualifier but don't add any actions to it.
    6. Edit the Set alterable value action then click OK.
    7. The Neutral qualifier has disappeared and cannot be added back in (until window is closed and opened again)
    Andy H @ ovine.net
    Awful Jokes - a new cartoon every day: http://awful.ovine.net/
    Ovine's games: http://www.ovine.net

  2. #22
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleSWF Export ModuleMac Export Module
    CapitaineCaverne's Avatar
    Join Date
    Feb 2011
    Location
    Bretigny sur Orge
    Posts
    466
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Bonjour Yves je suis tombe sur un petit problème avec une couleur et le curseur en utilisent la couleur de remplissage (128.128.128) sur l objet si on prend après outil brosse on a l 'impression que le curseur passe en dessous de la couleur (je pense que le curseur modifie sa couleur et a ce moment la il est de la même couleur grise.
    je jointe un exemple.
    Attached files Attached files

  3. #23
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,728
    Mentioned
    52 Post(s)
    Tagged
    2 Thread(s)
    Ah oui, faudra que je regarde ça.

  4. #24
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    562
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    the active system box was updated among background system box, just tested here and they have the fix when I built new final project
    It seems to happen only on my Samsung J3 2016, i'm using "fit Inside and adjust window", the app is in 853*480 on this device, here is a video of the issue:
    https://www.williambourdon.fr/files/spartanrunner.mp4

  5. #25
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    562
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    please check if you have these lines of code in your object CRuniOSSingleEdit.m
    I think i have found the problem, if we set "Disable" at start of frame, the ios single line will never respond to nay control anymore.
    Here's a MFA for example of the issue, on Windows you will see 2 edit box and only one on iOS.
    test2.mfa

  6. #26
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,749
    Mentioned
    101 Post(s)
    Tagged
    2 Thread(s)
    It seems to happen only on my Samsung J3 2016, i'm using "fit Inside and adjust window", the app is in 853*480 on this device, here is a video of the issue:
    https://www.williambourdon.fr/files/spartanrunner.mp4
    mix devices here I thought your report was for iOS, I will check then

    I think i have found the problem, if we set "Disable" at start of frame, the ios single line will never respond to nay control anymore.
    Here's a MFA for example of the issue, on Windows you will see 2 edit box and only one on iOS.
    test2.mfa
    sorry if the object is disable there is no control for this object , this limitation comes from iOS, I think you will need to add some code to enable-hide and then disable, the same for the counterpart
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  7. #27
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    562
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    the object is disable there is no control for this object , this limitation comes from iOS, I think you will need to add some code to enable-hide and then disable, the same for the counterpart
    I have no problem to use "disable" and keep control other the ios editbox, only the hide/show action isn't working.
    In my app, i use the disable function to force to close the keyboard. And then i enable the editbox When i need to use it.

  8. #28
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    562
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Even by removing "disable" at start, it doesn't fix my problem.
    It seems that if the ios edit box is outside of the frame and in a hide state at start, then the show action will not work. Even if the first event at start of frame is to change position of the editbox to the visible part of the frame.

    This MFA confirm it:
    test3.mfa

    I've wasted one entire day to find what's wrong with this object, so put it outside of the frame, uncheck visible at start or add a "start of frame - hide" and it will never be possible to show this editbox again.

  9. #29
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleXNA Export Module
    Dobermann's Avatar
    Join Date
    Feb 2009
    Location
    France
    Posts
    562
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    I've also noticed in that mfa, that the "set position" of the ios edit box isn't working the same way if the edit box is in the frame at start or outside the frame. (see test 2, positions on windows and ios are totally differents)

  10. #30
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    5,749
    Mentioned
    101 Post(s)
    Tagged
    2 Thread(s)
    I don’t have any bug after testing your mfa as example in devicethat have the approx same screen size, like Samsung ace 4.4.2 &Samsung note 3 Neo 5.1 I run , only some artifact that may appearsrandomly because it is recommended to use power of 2 textures,128x128, 512x512, 1024x256, etc when scrolling.


    about iOSSingleEditI will send you by PM a new object for you to try
    Regards,


    Fernando Vivolo

    ... new things are coming ...

Page 3 of 11 FirstFirst 1 2 3 4 5 ... LastLast

Similar Threads

  1. Build 287.2 - beta version
    By Yves in forum Fusion 2.5
    Replies: 55
    Last Post: 27th September 2016, 07:21 AM
  2. Build 287.1 - beta version
    By Yves in forum Fusion 2.5
    Replies: 21
    Last Post: 23rd July 2016, 02:40 PM
  3. Build 284.2 - beta version
    By Yves in forum Fusion 2.5
    Replies: 89
    Last Post: 17th April 2015, 04:41 PM
  4. Build 284.1 - beta version
    By Yves in forum Fusion 2.5
    Replies: 72
    Last Post: 2nd April 2015, 08:19 AM
  5. Build 283.1 - beta version
    By Yves in forum Fusion 2.5
    Replies: 19
    Last Post: 29th October 2014, 10:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •