User Tag List

Page 9 of 11 FirstFirst ... 7 8 9 10 11 LastLast
Results 81 to 90 of 104

Thread: Build 292.5 - Release version

  1. #81
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,126
    Mentioned
    76 Post(s)
    Tagged
    0 Thread(s)
    I've found some weird behaviour regarding Global Events and Qualifiers.

    I have a qualifier split between some counters and some sprites. Here they are in the Frame Event Editor. You can see the tooltip says "Sprite".



    I hit the keyboard shortcut to go to global events. Now the tooltip just gives me a generic qualifier for both:



    If I hit Ctrl-T to go to the Global Event List Editor, it also has generic qualifiers.



    But, if I double click a grid square in the Global Event Editor to see the Global Action Editor, it.......still has generic qualifiers:



    ........but once I hit escape out of the Global Action Editor, the Global Event Editor now has the non-generic qualifers:



    From this point on, I can hit Ctrl-T to go to the Global Event List Editor, and it also has the non-generic ones:



    The real qualifiers seem to remain until I leave the Global Events. But once I exit the Global Events and return, the qualifiers are generic again.

    I've attached a simple MFA that does the same thing (using default qualifiers). Notice also two things which may or may not be significant:

    - After you enter and exit the Global Action Editor for Global Event #1, all qualifiers are displayed correctly now. Even the Vehicles qualifiers, which aren't part of Global Event #1, and thus weren't featured in the Global Action Editor.



    -However, even when Foreground and Vehicle qualifiers are displaying correctly, if you try and import new objects into the Global Events, the Bomb qualifiers still only have generic names.



    I hope this helps.
    Attached files Attached files

  2. #82
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    94 Post(s)
    Tagged
    2 Thread(s)
    Yes, it's a known issue, described in the release notes (maybe I was not clear enough though), you should avoid using the same qualifier in several object types in global events / behaviors until this is fixed. Sorry for this issue.

  3. #83
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,126
    Mentioned
    76 Post(s)
    Tagged
    0 Thread(s)
    I knew that the names not showing up was a known issue, but you asked in another thread for people to report any weird findings about Global Events and Qualifiers. I figured that this behaviour, where entering and existing the Global Action Editor temporarily reveals correct names, might be unknown.

  4. #84
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    94 Post(s)
    Tagged
    2 Thread(s)
    Ah I see, thanks. Actually I started fixing it, I think what you reported is the result of this partial fix. This first attempt is not correct though, need to find a better solution...

  5. #85
    Clicker Fusion 2.5Fusion 2.5+ DLC

    Join Date
    Jun 2006
    Posts
    878
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am not 100% if this is related to this version, but I noticed that suddenly there is a 2-sec long lag when a sound is played for the first time (it has the option Preload set). My app consumes around 230 MB of memory when running, and this is truly a problem for me

  6. #86
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    94 Post(s)
    Tagged
    2 Thread(s)
    Hmm, in theory there is no change, unless you use the 2.5+ DLC (in this case try unchecking "Optimize Play Sample" in the properties of the application).

  7. #87
    Clicker Fusion 2.5Fusion 2.5+ DLC

    Join Date
    Jun 2006
    Posts
    878
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No, not using the DLC. The sound file is 9 Kb, I tried Play from disk or Load on call but the result is the same.

  8. #88
    Clicker Fusion 2.5Fusion 2.5+ DLC

    Join Date
    Jun 2006
    Posts
    878
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Huh, actually I can reproduce it even on a fresh app. In addition, whenever a sound plays, mouse cursor freezes. Could be something with my laptop (running on a corporate laptop where McAfee permanently does something..)? Attaching. soundTest.mfa

  9. #89
    Clicker Fusion 2.5 Developer

    Join Date
    Feb 2014
    Posts
    959
    Mentioned
    16 Post(s)
    Tagged
    1 Thread(s)
    @Fernando
    I figured out how the sound bug error occurs
    if u play 2 of the same sounds overlapping on different channels, then play the sound again BEFORE letting the previous samples finish playing then it kicks in and only plays one at a time. but if you wait until the samples have all finished playing, then it lets you play them overlapping the next time.

    so in my example you would simply tap red, blue, red & it should cut out & only play 1 sample on the red channel.

    hope this helps find the fault.

  10. #90
    Clicker Fusion 2.5Fusion 2.5+ DLC

    Join Date
    Jun 2006
    Posts
    878
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think my problem is not related to the latest build, removing from here and starting another thread.

Page 9 of 11 FirstFirst ... 7 8 9 10 11 LastLast

Similar Threads

  1. Build 287.2 - beta version
    By Yves in forum Fusion 2.5
    Replies: 55
    Last Post: 27th September 2016, 07:21 AM
  2. Build 287.1 - beta version
    By Yves in forum Fusion 2.5
    Replies: 21
    Last Post: 23rd July 2016, 02:40 PM
  3. Build 284.2 - beta version
    By Yves in forum Fusion 2.5
    Replies: 89
    Last Post: 17th April 2015, 04:41 PM
  4. Build 284.1 - beta version
    By Yves in forum Fusion 2.5
    Replies: 72
    Last Post: 2nd April 2015, 08:19 AM
  5. Build 283.1 - beta version
    By Yves in forum Fusion 2.5
    Replies: 19
    Last Post: 29th October 2014, 10:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •