User Tag List

Results 1 to 4 of 4

Thread: Direct3d 11 and Sub Application Issue

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    144
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Direct3d 11 and Sub Application Issue

    Hi, I have a sub application (a kind of launch screen) that when I run alone looks great. However, when I run it from the main application, the transparencies seem to get disabled.

    I have tried switching Premultiplied alpha off/on which seems to work for the launcher but then at the same time messes up the look of my main application somewhat. The only way it does work fully (good transparencies on both apps) is if I set the sub application to Direct x 11 and the main app to Dircetx 9, but obviously I'd like to keep the benefits of Dx11 in my main app.

    I cant find a way to switch display modes during runtime so I was wondering if anyone might have a solution for this?

    I could rebuild all my art in the launcher without transparencies but that would take me a while.

    Any ideas?

    Thanks

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,757
    Mentioned
    64 Post(s)
    Tagged
    2 Thread(s)
    If you could make a simple example that shows the problem and post it here or send it to me by pm (If that works), I'll take a look on Wednesday.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    144
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Hi Yves, no worries. In the end I've just started to just re work the launch screen without any alphas. I'd need to go backwards to get you a demo now so I'm not gonna be able to send you a version. I was in a bit of a hurry to make the decision so I had to just bite the bullet. Thanks anyway.

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCiOS Export ModuleInstall Creator Pro
    Julian82's Avatar
    Join Date
    May 2012
    Location
    outbuddies.com
    Posts
    887
    Mentioned
    43 Post(s)
    Tagged
    0 Thread(s)
    I can confirm that there's a transparency issue with sub-application, happens in DX9 mode here too. Did not realize it before 292.5, but I could be mistaken here. Unfortunately I'm not able to reproduce the issue with a simple .mfa. I tried, but it only happens in my main project. The Sub-App menu has a custom Fade in Fx, which is just a black layer on top of everything that is getting transparent. However, some objects, not everything tho, behind this layer are not shown while the fade-in happens, then suddenly pop up when the top layer reaches full transparency (255). Minor thing for me, but I'll also try to boil it down to something you can work with.

Similar Threads

  1. Direct3D 9 Anti-Aliasing Issue
    By LavaFlaminG6 in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 3rd August 2013, 11:53 AM
  2. Sub application Issue
    By TedBoomerang in forum SWF/Flash Export Module Version 2.0
    Replies: 6
    Last Post: 2nd June 2011, 08:17 PM
  3. Jar Application Opnening Issue
    By Fanotherpg in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 21st November 2010, 04:17 PM
  4. sub application issue
    By willow in forum Multimedia Fusion 2 - Technical Support
    Replies: 4
    Last Post: 21st February 2010, 12:55 PM
  5. Sub-Application Issue
    By MikeB in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 10th November 2008, 09:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •