User Tag List

Results 1 to 4 of 4

Thread: Disappearing Animation Not Playing, 2.5+

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleMac Export Module
    dsilvers's Avatar
    Join Date
    Jun 2008
    Location
    Boston, MA
    Posts
    495
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)

    Disappearing Animation Not Playing, 2.5+

    I've found a few threads on this from many years ago, but it seems to be an issue that was never fixed. The issue is that the Disappearing animation doesn't seem to play on anything but immediate/green events. For instance, if you have an active object with an Alterable Value Health, and when Health = 0 it gets destroyed, with a Disappearing animation, that animation won't play. However, if you have "Player Left Clicks on Active" and "Destroy" then the Disappearing animation will play. Yes I can spawn the destroy animation as a separate object, but when it comes to optimizing code and keeping object counts down, it'd be nice to have this option.

    I've attached a small MFA to demonstrate this bug in action.

    healthbug.mfa

    Appreciate any help!

  2. #2
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLC
    Tek's Avatar
    Join Date
    Jul 2007
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you add the action Restore Animation Frame right before the Destroy action, the animation will play and then the object will be destroyed after. I'm not very familiar with forcing animation frames, but I think the event that forces the animation frame causes the animations to just stop playing or something, and it stays that way until it's 'rebooted' back to normal with something like a Restore action?
    Images attachées Images attachées

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleMac Export Module
    dsilvers's Avatar
    Join Date
    Jun 2008
    Location
    Boston, MA
    Posts
    495
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Wow that actually worked! Thank you!

    I feel like that needs to be something that's baked into Fusion's backend somehow. Really weird but good to know.

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLC
    Tek's Avatar
    Join Date
    Jul 2007
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No problem.

    Yeah it's not exactly the most straightforward way that one might expect it to work. Not sure why it's like that. Maybe it's important for it to work that way so something else can work properly in certain scenarios somehow.

Similar Threads

  1. Animation not playing at all
    By Outcast in forum Android Export Module 2.5
    Replies: 11
    Last Post: 2nd January 2015, 06:40 PM
  2. Destroyed enemy vanishing, not playing "disappearing" animation
    By Sterling7 in forum The Games Factory 2 - Technical Support
    Replies: 5
    Last Post: 17th July 2013, 03:21 AM
  3. Animation x is playing - problem
    By wizlore in forum Multimedia Fusion 2 - Technical Support
    Replies: 3
    Last Post: 25th September 2012, 12:08 PM
  4. Actives with disappearing animation not really destroyed
    By JoKa in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 28th February 2012, 08:41 AM
  5. disappering animation not playing
    By willow in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 16th May 2010, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •