User Tag List

Results 1 to 4 of 4

Thread: Load/Save file in editbox stops ScreenCapture from working.

  1. #1
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Dec 2010
    Posts
    120
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Load/Save file in editbox stops ScreenCapture from working.

    I've encountered a BUG while building the onionskin feature for Clickpuppet. It works perfectly until I use the editbox feature to load or save an external string, whereupon no more images are captured. I've attached a stripped down mfa which has the same issue. If you start the ap and hit 1 to begin capture the capture works. if you hit the 2 or 3 key to load or save text from the editbox and then hit 1, no images are saved.
    screencap.zip

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,092
    Mentioned
    123 Post(s)
    Tagged
    2 Thread(s)
    I think it's because you didn't mention a full pathname for the capture filename, so the pathname depends on the current directory that was probably modified by the Edit Box object.

    Just add Apppath$ to the expression:

    Apppath$ + "screencap/screen" + Str$(Global Value C) + ".bmp"

  3. #3
    Clicker

    Fusion 2.5 DeveloperFusion 2.5+ DLCHTML5 Export ModuleiOS Export ModuleSWF Export Module
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Dec 2010
    Posts
    120
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    User error :)

    Thanks Yves. That fixed it. Damnable user error
    Is there any way for me to edit my earlier post so that I can put that in the title? I seem to be able to edit later posts but not the thread starter.

  4. #4
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,092
    Mentioned
    123 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by JohnArtbox View Post
    Is there any way for me to edit my earlier post so that I can put that in the title? I seem to be able to edit later posts but not the thread starter.
    Done (I've removed BUG). You can do it if you click "Go Advanced" (unless it's an admin feature).

Similar Threads

  1. Replies: 5
    Last Post: 14th November 2018, 02:58 PM
  2. Save & Load file with UWP application ?
    By BenjaminG in forum Universal Windows Platform Module 2.5
    Replies: 6
    Last Post: 14th November 2016, 11:34 AM
  3. LOAD/SAVE clone file in ARRAY FILE
    By daniele in forum Multimedia Fusion 2 - Technical Support
    Replies: 20
    Last Post: 24th July 2015, 01:47 AM
  4. Save and load frame not working at all
    By Maggott in forum Multimedia Fusion 2 - Technical Support
    Replies: 15
    Last Post: 15th March 2008, 11:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •