User Tag List

Results 1 to 6 of 6

Thread: Object border glitch (at runtime on device)

  1. #1
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export Module

    Join Date
    Jun 2006
    Posts
    173
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Object border glitch (at runtime on device)

    Hello there,

    I'm dealing with a curious visual glitch on Android runtime.

    Running on MMF, everything is fine:
    https://www.dropbox.com/s/n5yz2ml6lg...20MMF.png?dl=0

    But, when running on the device, several object borders are glitched:
    https://www.dropbox.com/s/ms9zdm7qx9...evice.png?dl=0

    Example file: https://www.dropbox.com/s/26knwrrrxp...%20CT.zip?dl=0

    I'm using Clickteam Fusion 2.5 Developer build 292.10.

    What could be the cause of the problem?!?
    Thank you very much for the support!!

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,089
    Mentioned
    123 Post(s)
    Tagged
    2 Thread(s)
    I think I remember I got a similar issue in this build during a test and switching from OpenGL 1.1 to OpenGL 2.0 in the Android properties fixed it. And IIRC we're going to drop OpenGL 1.1 (I need to double-check with Fernando before we release the next update).

  3. #3
    Clicker Fusion 2.5 DeveloperAndroid Export ModuleiOS Export Module

    Join Date
    Jun 2006
    Posts
    173
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    It seems to be working now, thank you!!

    P.s. in the Android properties there is also the option to use OpenGL 3.0.. the aforementioned problem seems to be fixed with both 2.0 and 3.0.
    In your opinion would it be preferable to use 3.0 directly instead of 2.0?
    Or are there possible disadvantages, such as possible compatibility issues?

  4. #4
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    193
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Fyi, in my case, when I tried to upload to Google Play with Opengl 3.0, it gave me a big warning, telling me that half of the android devices wouldn't be supported anymore. I heard of someone else getting the same message too. I don't know if you need to do something else to build it for those other devices, or if that's just how Opengl 3.0 works, but if you simply change from Opengl 2.0 to 3.0 and try to upload it to Google Play, that's what's going to happen.

  5. #5
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,150
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    Quote Originally Posted by Nemeean_lion View Post
    Fyi, in my case, when I tried to upload to Google Play with Opengl 3.0, it gave me a big warning, telling me that half of the android devices wouldn't be supported anymore. I heard of someone else getting the same message too. I don't know if you need to do something else to build it for those other devices, or if that's just how Opengl 3.0 works, but if you simply change from Opengl 2.0 to 3.0 and try to upload it to Google Play, that's what's going to happen.

    latest version will remove the opengl filter that affect number of devices available when you upload and apk using version 3.0, so in next version you may set 3.0 and you will get the same number of devices than 2.0
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #6
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)iOS Export Module (Steam)

    Join Date
    May 2014
    Posts
    193
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Nice! That's good to hear.

Similar Threads

  1. Border color runtime changes
    By qobion in forum Fusion 2.5
    Replies: 2
    Last Post: 29th July 2016, 09:52 PM
  2. Border Color -> Border Pattern?
    By Bipolar_Games in forum Multimedia Fusion 2 - Technical Support
    Replies: 13
    Last Post: 9th February 2013, 12:50 PM
  3. White Border Glitch
    By Pixzel in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 30th July 2010, 12:06 AM
  4. Object lag glitch
    By User77 in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 4th September 2008, 01:15 AM
  5. Thick non wanted border with direct show object
    By Tiny in forum Multimedia Fusion 2 - Technical Support
    Replies: 6
    Last Post: 28th May 2007, 01:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •