User Tag List

Results 1 to 10 of 10

Thread: Set Window Shape not working in build only (Fine from editor)

  1. #1
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    200
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Set Window Shape not working in build only (Fine from editor)

    Set Windows Shape (from Active Object) works perfectly well during testing (running from the editor) but as soon as I make a build and execute the Set Shape action nothing happens. Windows exe.

    Any ideas?

    v292.10

  2. #2
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    93 Post(s)
    Tagged
    2 Thread(s)
    Seems ok. Maybe you should post an example.

  3. #3
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    200
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    Seems ok. Maybe you should post an example.
    Hmm, I tried a simple comparative example with all the same settings which works fine in a built and editor version.

    I then tried various different things all morning but I'm still clueless. I just don't understand how the build can be so different from the editor version.

    Any chance I could post the project for you to check out?

    Basically you just need to hit the + or - key to see the masking effect. (which works in editor but not in build)

  4. #4
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    200
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Well I've found the issue. Basically it has nothing to do with the WIndow Shape object but 'possibly' to do with child events or something else. Either way..its madness.

    Basically I have a function which runs when I want to create the window mask effect that behaves differently in build/editor version.

    In the built version the child events from the function never get called even though they do in the test version (straight from fusion)

    Now in the built version IF I simply add a line of irrelevant debut text (or maybe this could be any line of code I haven't tried yet) then the child events get triggered fine.

    https://www.screencast.com/t/eoQVLFD9b4gl

    Something very odd going on.

  5. #5
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    200
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    I swapped out the whole function with a timer event and I still get the same issue.

  6. #6
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    200
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by grimmy View Post
    I swapped out the whole function with a timer event and I still get the same issue.
    Cancel that, with a timer set to 0 instead of a function it works. I am confused.

  7. #7
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    93 Post(s)
    Tagged
    2 Thread(s)
    Hmm, I wonder if it could be the problem with object selection in child events that was reported a couple of days ago. Perhaps I could send you a new version of Fusion for you to check if it fixes the problem.

  8. #8
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    93 Post(s)
    Tagged
    2 Thread(s)
    I've sent you a PM with the new version, let me know.

  9. #9
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    12,917
    Mentioned
    93 Post(s)
    Tagged
    2 Thread(s)
    BTW, any news? Have you been able to test your app with the new version of Fusion?

  10. #10
    Clicker Fusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleiOS Export ModuleSWF Export ModuleInstall Creator Pro

    Join Date
    Apr 2008
    Posts
    200
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Yves View Post
    BTW, any news? Have you been able to test your app with the new version of Fusion?
    Yes, I'm using the new version now and everything seems fine. I haven't specifically tested the exact bug I was looking at before because I'd been able to resolve it with the timer.

    Although I have noticed a few 'permission based' issues which only seemed to crop up since updating from 292.8. Notably desktop shortcuts (.lnk files) not having enough permission for the ishellLink plugin and the Advanced Menu object suddenly complaining about permission when trying to create a new menu...but only sometimes. I dont know if its all related. The menu stuff especially always worked fine even in the version you sent me with the changes to the admin mode stuff for the drag and drop so not sure why that's started to happen.

Similar Threads

  1. Fine detection is not working?
    By twister in forum Multimedia Fusion 2 - Technical Support
    Replies: 0
    Last Post: 22nd January 2014, 10:36 AM
  2. Can't Minimize With Window Shape
    By catdogck in forum The Games Factory 2 - Technical Support
    Replies: 2
    Last Post: 15th March 2012, 03:26 AM
  3. Help Required - Window Shape
    By Spryz in forum Multimedia Fusion 2 - Technical Support
    Replies: 2
    Last Post: 19th September 2011, 09:25 AM
  4. [BUG] Window Shape Object
    By Locaz00 in forum Extension Development
    Replies: 2
    Last Post: 15th April 2009, 12:17 PM
  5. [Suggestion] Extra shape for Window Shape object
    By LIJI in forum Multimedia Fusion 2 - Technical Support
    Replies: 1
    Last Post: 5th March 2007, 06:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •