I know I have read that shorter loop names are faster than longer ones because a shorter search is needed for finding the loop. I don't know how big impact this has though, if any. Do anyone know?
For example if I do a regular loop or a foreach loop and name it something short like "1" vs something descriptive like "finding_the_apple".
Of course I like to have descrpitpive loop names as it is much easier to read that code, but if there is a big performance loss for it that would be non-optimal..