User Tag List

Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19

Thread: Get Object not working with HTTP

  1. #11
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    Yes, but to not add sub domain which will make things not simple

    I will send you a PM with a link with a RuntimeAndroid.zip for you to try there
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  2. #12
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    93
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fernando View Post
    Yes, but to not add sub domain which will make things not simple

    I will send you a PM with a link with a RuntimeAndroid.zip for you to try there
    Hello @Fernando ,

    did you find a solution for this problem ?

    thanks,
    Haoujey

  3. #13
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    this is solved in next beta for http which is the problem, normally android wants you to use https.
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  4. #14
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    93
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @Fernando can you send me the fixed file please ? i don't want to take the risque of upgrading to a beta.

    I have a problem even with some https adresses.
    I spent two weeks upgrading all my servers to https and still not work.

    When i call my api (https) in the windows emulation it works. When i compile it and send to the android emulators (api 25 / 27 / 29), i get a timeout with a 12044 error.

    When i call the same url in the emulator's browser it connects and gets the correct respons.

    I can send the example mfa via mp if needed.

  5. #15
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    please send me a small maf with these url for me to test here
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  6. #16
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    93
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @Fernando . link to MFA sent in mp.

  7. #17
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    93
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    @Fernando , have you been able to reproduce the problem with my example ?

  8. #18
    Clickteam Clickteam
    Fernando's Avatar
    Join Date
    Dec 2006
    Posts
    6,143
    Mentioned
    158 Post(s)
    Tagged
    3 Thread(s)
    there is a connection issue between android and the cloud service, not related to the change requested for android 7+


    ====================================

    this issue need to be review by you with the https provider


    Error: api.join.cloud/services/ is not a fully qualified public domain name or public IP address.

    this generate a handshake error
    Regards,


    Fernando Vivolo

    ... new things are coming ...

  9. #19
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    May 2017
    Location
    Nantes
    Posts
    93
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    thanks Fernando. I wasn't able to find what's blocking.

    Problem solved.

    If others encounter the same problem, it's due to Android strict SSL rules. All the certification chain must be present.
    So if you use letsencrypt to generate your cetificates, concatenate your certificate.crt with the ca_bundle.crt to get the full chain.

    Haoujey

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Replies: 0
    Last Post: 10th February 2015, 01:29 PM
  2. HTTP request
    By Pompos in forum Fusion 2.5
    Replies: 5
    Last Post: 10th April 2014, 11:18 PM
  3. HTTP Downloader Object?
    By Darkhog in forum Extension Development
    Replies: 2
    Last Post: 26th February 2009, 10:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •