User Tag List

Page 2 of 2 FirstFirst 1 2
Results 11 to 18 of 18

Thread: INI Crash and Slowdown

  1. #11
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,306
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    I'm confused. Here you say that you think it's an action that's causing the problem

    Quote Originally Posted by wii1mii View Post
    Issue was rather not in:



    But in:



    But here you seem to suggest that you think it's a condition that causes the problem.

    Quote Originally Posted by wii1mii View Post


    I guess that narrows it down to OR actually making fusion to check for every condition in the line, I guess that makes sense now that i think about it.

    To me, it seems like the problem is about a condition rather than an action. Even if it's an action that causes the lag, the mystery is - as you said earlier - why certain conditions are allowing that action to trigger at all.



    Do you get the slow down if you replace this




    with this?


  2. #12
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    wii1mii's Avatar
    Join Date
    Sep 2012
    Location
    Estonia
    Posts
    103
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    From my understanding:

    When ini is set to an actual file then the condition actually loads the file to check if the length matches.
    Loading file so many times causes lag when something rather heavy is performed.

    Now no matter about the beginning condition, as soon as the ini file assign action is performed everything slows down.

    However once i removed OR performance was back to what it used to be.

    So thats why i suggest that the OR forces fusion to actually check every condition in the line.

    --
    I mean i tried to change

    To "On button press" and as soon as i pressed button it started laging, so has to be action.

  3. #13
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,306
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    But why does cause lag but "on button press" doesn't?

    I'm thinking that the problem might be with the "on loop LangSwitch", which is not green (but it should be!). I wonder if it's being somehow ignored and - since it's been ignored - effectively treated as an "always" condition, which makes the action trigger each frame. What happens if you replace Start of Frame with a black condition that returns false (which would make On loop LangSwitch become green as it should be)? Does it still cause lag? That's why I'm asking you to try this :


  4. #14
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    wii1mii's Avatar
    Join Date
    Sep 2012
    Location
    Estonia
    Posts
    103
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Here,

    I hope this makes some more sense:
    https://upload.catgc.com/img/7f764e4...e4b1cb1c74.mp4

  5. #15
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,306
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    So it lags when you press control? Well that's as expected. But the mystery is why it also lags when it has an "on loop" condition even when you don't call the loop. What happens when you replace start of frame with a black condition, as above? Does the action still get activated?

  6. #16
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    wii1mii's Avatar
    Join Date
    Sep 2012
    Location
    Estonia
    Posts
    103
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    https://upload.catgc.com/img/a9224b8...2e05cec3e2.mp4
    Even with first even being black it still lags yes.

  7. #17
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,306
    Mentioned
    94 Post(s)
    Tagged
    0 Thread(s)
    ok, thanks for humouring me and checking that. I thought that maybe the problem was that when "on loop" was black instead of green, it ceased working properly. But that doesn't seem to be the problem.

    So actions that are not actually played can still slow down the runtime. Weird. Actually, this reminds me of something casleziro wrote in another thread recently. I guess it might be connected, since both are unplayed actions that cause Fusion to load stuff:

    Quote Originally Posted by casleziro View Post
    I recall Nifflas using "Never" to "load sounds" into Fusion memory at start in one of his sound engines. It was just a "Never" condition with a bunch of "play sound x" events in it. I'm not positive, but I assume Fusion will load these sounds since they're referenced, even if they are never played? He had a comment that said the line was to do just that to avoid a small lag the first time a sound is played.

  8. #18
    Clicker Fusion 2.5 MacFusion 2.5 DeveloperFusion 2.5+ DLCAndroid Export ModuleHTML5 Export ModuleiOS Export ModuleUniversal Windows Platform Export ModuleSWF Export ModuleInstall Creator Pro
    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    wii1mii's Avatar
    Join Date
    Sep 2012
    Location
    Estonia
    Posts
    103
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Well like i mentioned, there are few workarounds.

    a) "Start of frame"/"On loop" [enable group] to load in the ini and go though every event and at the end [disable group].
    b) Remove "OR" from the condition and only use loop (currently using that)

    Theoretically could combine both but i dont see a reason for that.

    c) Use loop to point towards INI file and at the end point towards file that does not exist. This is a dumb work around but theoretically it works.

    None the less, thanks for being here and helping me out

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Major slowdown leading to crash
    By Warmachine in forum Fusion 2.5
    Replies: 15
    Last Post: 31st May 2014, 09:44 AM
  2. slowdown in mmf!
    By Mart393 in forum Hardware Accelerated Runtime
    Replies: 0
    Last Post: 31st October 2013, 07:17 PM
  3. [CRASH] Google Play Crash Report: java.lang.NullPointerException
    By tom79 in forum Android Export Module Version 2.0
    Replies: 1
    Last Post: 1st August 2013, 05:08 AM
  4. [CRASH] Memory Object Runtime Crash with Allocate(
    By LB in forum Extension Development
    Replies: 8
    Last Post: 4th September 2011, 10:04 AM
  5. Causes of slowdown
    By stuckboy in forum Multimedia Fusion 2 - Technical Support
    Replies: 8
    Last Post: 22nd December 2007, 10:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •