User Tag List

Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: Crash bug need help

  1. #1
    Clicker

    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    callofAS's Avatar
    Join Date
    Jan 2017
    Location
    China
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation Crash bug need help

    hi, My English is not good.
    I found that If I changed some icons or renamed something in the qualifier, and then edit an object's qualifier.
    and then, If I move this object in the frame editor, the Fusion will be crashed.
    I tested that even an MFA with no events is also like this.

    And I am use the Steam version Fusion2.5+, 292.14.
    It did not happen in the previous versions.
    I can not fix it by reinstall Fusion in Steam. I am a rookie on the computer side.
    If you know how to fix this, please tell me.

    p.s. It also looks weird in the object's properties. but not in other places.
    TIM截图20190909130315.jpg
    TIM截图20190909130349.jpg

  2. #2
    Clicker

    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    callofAS's Avatar
    Join Date
    Jan 2017
    Location
    China
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I solved this problem.
    It still looks weird in the object's properties. But Fusion is not crashed.

    Here is what I did if other people have the same problem:
    1. delete the "mmf2u.exe".
    2. do the "Verify Integrity of Game Cache..." of your Fusion in the Steam Library.

    I found a thread, A bro said he had hacked the .exe to change the qualifiers. So these qualifiers are in the .exe file.
    I also confused that to reinstall fusion in steam is not work. but this way works. but finally I can continue my work.

  3. #3
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Feb 2017
    Posts
    338
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    I have this damaged qualifier images in the properties also since few versions.

    I tried the above but didn't help.

  4. #4
    Clicker

    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    callofAS's Avatar
    Join Date
    Jan 2017
    Location
    China
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    p.s.
    I have been in this problem for 3 consecutive days.
    today a crash window says:
    Exception thrown in destructor
    (d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmf c\src\mfc\winfrm.cpp:159)
    Encountered an unsuitable parameter

  5. #5
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    Volnaiskra's Avatar
    Join Date
    Jan 2014
    Location
    www.sprykegame.com
    Posts
    2,245
    Mentioned
    87 Post(s)
    Tagged
    0 Thread(s)
    In terms of the glitchy qualifier icons, it might be caused by alpha channels. I did a bit of investigating of which image formats work best for the custom qualifiers when I was making my super fantastic icon pack (←plug), and this is what I found. Maybe it'll help:

    This isn't to do with renaming qualifiers, but beware that using alpha channels in the custom qualifier icons is problematic. They look good in the icon editor, but then they end up screwed up in the actual MFA (eg. object properties, events). Transparent areas become solid black, for example, or other glitchy artifacts.

    I've tried PNG32s, PNG8s with translucency (I didn't even know this was a thing until today) and PNG8s with binary transparency, and none of them work. Sometimes it appears to import the alpha channel, but then you see solid pixels in the MFA. GIFs seem to work, though they only have binary transparency, which doesn't look great in many cases.

    I also managed to get a working alpha channel by importing a PNG8 with a solid background and using the "choose transparent color" feature when importing in Fusion. Even this method didn't work with a normal PNG32 - Fusion doesn't seem to be able to read the colors correctly on PNG32s when importing the qualifier icons, so you'll create an icon with a #000000 background, for example, and tell Fusion that #000000 should be transparent, but it'll import the black pixels as black anyway.

    The weird thing is that the whole icon importing experience looks and feels pretty much just like the normal graphic importing experience in Fusion (eg. importing into active objects), which has none of these problems.

    Anyway, I've resigned myself to just using white backgrounds on all my icons, and that works pretty well. The white edges are visible a little bit (on certain parts of the interface more than others), and for some reason Fusion changes them from pure white to a slightly greenish white, but these are minor issues. In regular use you don't notice.
    (quote above is pasted from this thread)

  6. #6
    Clicker

    Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)
    callofAS's Avatar
    Join Date
    Jan 2017
    Location
    China
    Posts
    21
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thank you, Volnaiskra.
    I will try this.

  7. #7
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Feb 2017
    Posts
    338
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    I dont use any custom qualifiers or modifications, everything is as it is out of the box.

  8. #8
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,088
    Mentioned
    123 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by Manuel View Post
    I dont use any custom qualifiers or modifications, everything is as it is out of the box.
    Weird. Could you post a MFA that shows this problem please?

  9. #9
    Clickteam Clickteam

    Join Date
    Jun 2006
    Location
    France
    Posts
    13,088
    Mentioned
    123 Post(s)
    Tagged
    2 Thread(s)
    Quote Originally Posted by callofAS View Post
    p.s.
    I have been in this problem for 3 consecutive days.
    today a crash window says:
    Exception thrown in destructor
    (d:\agent\_work\3\s\src\vctools\vc7libs\ship\atlmf c\src\mfc\winfrm.cpp:159)
    Encountered an unsuitable parameter
    This error doesn't seem to come from Fusion. Maybe another program running in the background is intercepting the interface of other running apps on your machine?

  10. #10
    Clicker Fusion 2.5 (Steam)Fusion 2.5 Developer (Steam)Fusion 2.5+ DLC (Steam)Android Export Module (Steam)HTML5 Export Module (Steam)iOS Export Module (Steam)Universal Windows Platform Export Module (Steam)

    Join Date
    Feb 2017
    Posts
    338
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Ok here, but i think its not because of the saved mfa, because when i open old mfa's even from other people it shows the same (and i never saved them, just opening it caused this). Qualifiers are ok everywhere except the properties.
    Only thing beside fusion update i did recently is install the nvidia driver 431.60, but dont know if this can cause something like that.
    Images attachées Images attachées
    Attached files Attached files

Page 1 of 2 1 2 LastLast

Similar Threads

  1. Replies: 0
    Last Post: 9th August 2019, 10:31 AM
  2. [CRASH] Google Play Crash Report: java.lang.NullPointerException
    By tom79 in forum Android Export Module Version 2.0
    Replies: 1
    Last Post: 1st August 2013, 04:08 AM
  3. [CRASH] Memory Object Runtime Crash with Allocate(
    By LB in forum Extension Development
    Replies: 8
    Last Post: 4th September 2011, 09:04 AM
  4. [CRASH] ForEach object crash on recursive loop
    By LB in forum Extension Development
    Replies: 0
    Last Post: 1st May 2011, 01:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •