I didn't got this warning with the new admob extension. So, the issue was coming from the use of the old Admob SDK.